Results 1 to 4 of 4

Thread: Ignition switch slipping 2010 K1300GT

  1. #1

    Ignition switch slipping 2010 K1300GT

    Hey guys. Sorry if there's a thread about this already but I didn't see one.

    My husband and I both have K-GTs. His is a 2010 and on our last trip his key started rotatating freely in the ignition switch. It no longer clicks in each position. Has this ever happened to anyone? Anyone know what is involved with fixing?

    Thanks!

  2. #2
    not so retired henzilla's Avatar
    Join Date
    Sep 2006
    Location
    CENTEX USA
    Posts
    10,922
    Do y’all have a second key to try?

    If the key cycles on/ off and bike runs would think a key module #1, if no power on/ off it could be the lower electric part of switch #2
    The common failure is a random no power that sometimes can be remedied turning key on and off many times until that stops working!

    Didn’t see #1 which holds the key cylinder listed separate on a list on the small screen


    12ACDEF2-C23B-4D85-A89B-6F87567A09AE.png

    The two screws shown , #3,are tamper proof and will need to be drilled out, all upside down! Doable but a PITA
    Steve Henson-Mod Team and past prez SABMWRA

    Be decisive, right or wrong.The road of life is paved with
    flat squirrels who couldn't make a decision~unknown

  3. #3
    Full power but no click between positions. Didnt think to try another key. We can do that. Our dealership did the fuel pump recall on it today and the guy was clueless about resolving the ignition issue.

  4. #4
    Fortis Fortuna Adiuvat Omega Man's Avatar
    Join Date
    Jan 2010
    Location
    Mansfield,MA
    Posts
    16,572
    Quote Originally Posted by heathergal View Post
    Hey guys. Sorry if there's a thread about this already but I didn't see one.

    My husband and I both have K-GTs. His is a 2010 and on our last trip his key started rotatating freely in the ignition switch. It no longer clicks in each position. Has this ever happened to anyone? Anyone know what is involved with fixing?

    Thanks!
    Welcome to the forum!
    I would try flushing the lock with WD-40 and then working the key. After a few rounds you should be able to “feel” something trying to rub to the stops.
    Good luck.
    Gary
    "You can do good or you can do well. Sooner or later they make you choose." MI5
    Mod Squad
    2009 F800GS 1994 TW200

Similar Threads

  1. 2010 K1300GT Advice
    By matchless1227 in forum Wedge K-bikes
    Replies: 8
    Last Post: 01-25-2014, 06:41 PM
  2. 2010 k1300gt
    By papaed in forum Wedge K-bikes
    Replies: 10
    Last Post: 07-07-2011, 12:31 PM
  3. K1300GT starter switch problem
    By Doktork13 in forum Wedge K-bikes
    Replies: 5
    Last Post: 07-12-2009, 10:20 PM
  4. K1300GT hi beam switch
    By roncooper in forum Wedge K-bikes
    Replies: 3
    Last Post: 05-25-2009, 06:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •