Results 1 to 6 of 6

Thread: Media Player App on Nav V

  1. #1
    Registered User
    Join Date
    Jan 2015
    Location
    Pickering, ON, Canada
    Posts
    132

    Media Player App on Nav V

    So, I've had my Nav V for 7 years and it's worked great. Until recently, it has just been used on my 2014 RT which is equipped with a radio and so I haven't used the Media Player app.

    I now have added a 2017 GSA to the "stable" and decided to use the Media Player in place of a radio. My first issue was that when I created an MP3 directory on the external memory (SD card) I have in the Nav V, and loaded some MP3 files on to it, the Media Player would give me an error saying that no MP3's were found. I've got past that issue by creating an MP3 folder in the internal memory and loading ONE MP3 file into it and having the balance of the MP3 files on the external memory card. The Media Player app now starts with that ONE MP3 file, but when I browse files in the Media Player, I see all of the files in both MP3 directories and can play them all.

    I have tried now removing the MP3 file on the internal memory, or just having it empty, but it only works when there is an MP3 folder on the Internal Memory with at least one song file in the folder. The manual clearly says that you can have the MP3 folder on either the internal or external memory ...

    Is this expected/normal?

    Next issue, which I have not found a work around for yet, is that the "two MP3 Folder" setup works fine until I shut down the bike. After the bike has been shut down, when I next restart motorcycle and the Media Player App if I press the Browse button the whole Nav V crashes and will restart/reboot. It will then work fine again until the next time I shut down and restart the motorcycle. Is this a known bug?

    I have also noticed a bunch of strange behaviors when I move the Nav V between the two bikes - settings (like "Auto" in the Brightness setting) getting cleared, etc., but I can live with those.

    The Nav V has been fully updated from Garmin Express - is ther an update for the Media Player or something I am doing wrong?

    Bob
    2014 R1200RT
    2017 R1200 GSA

  2. #2
    Registered User
    Join Date
    Jun 2015
    Location
    College Station, TX
    Posts
    86
    Quote Originally Posted by bobs_one View Post
    So, I've had my Nav V for 7 years and it's worked great. Until recently, it has just been used on my 2014 RT which is equipped with a radio and so I haven't used the Media Player app.

    I now have added a 2017 GSA to the "stable" and decided to use the Media Player in place of a radio. My first issue was that when I created an MP3 directory on the external memory (SD card) I have in the Nav V, and loaded some MP3 files on to it, the Media Player would give me an error saying that no MP3's were found. I've got past that issue by creating an MP3 folder in the internal memory and loading ONE MP3 file into it and having the balance of the MP3 files on the external memory card. The Media Player app now starts with that ONE MP3 file, but when I browse files in the Media Player, I see all of the files in both MP3 directories and can play them all.

    I have tried now removing the MP3 file on the internal memory, or just having it empty, but it only works when there is an MP3 folder on the Internal Memory with at least one song file in the folder. The manual clearly says that you can have the MP3 folder on either the internal or external memory ....

    Is this expected/normal?
    I set my Nav V up a long time ago, so to refresh my memory, I just plugged it into my laptop (Mac) to see how the storage is configured.

    There are two volumes, both are formatted as FAT32. The internal storage is named "GARMIN". The external 64 GB flash card is named "BMW NAVIGAT". It currently has about 10 GB of music on it. There is a directory (folder) named "MP3" on the external flash. Inside the MP3 folder, my music is organized into directories by artist name, then album name, then song, with numbers at the beginning of each song (e.g., "01 song name"). The external volume also has a file named "Id.txt" that contains some kind of ID string, and a "Garmin" directory containing three files: "gmapprom.gma", "gmapprom.unl", and "gmappupdate.gsd". I don't know if those files are required, or are leftovers from earlier attempts to install maps, etc. This setup works for me, as I'm able to browse my music in the Media Player app.

    There is no "MP3" folder on the internal drive. Hope this helps.

    Cheers, Ken
    2015 R1200GS

  3. #3
    Registered User
    Join Date
    Jan 2015
    Location
    Pickering, ON, Canada
    Posts
    132
    Thanks Ken. My setup is pretty much the same - but I have to have an MP3 folder on the internal memory in addition to the the MP3 folder on the external memory, or the Media Player gives me an error message saying that I need to put my songs into the MP3 folder (even though I have). And, even more problematic is the fact that it always crashes the NAV V the second time I try to run the media player (after restarting the motorcycle).

    It works well enough for me to play music, but it is annoying to have the unit reboot every second time.
    Bob
    2014 R1200RT
    2017 R1200 GSA

  4. #4
    Registered User
    Join Date
    Dec 2015
    Location
    Guelph, ON Canada
    Posts
    41
    Bob,

    I've had to keep one MP3 file on my internal drive (Nav V) and the remainder MP3 files on my SD card in order for music to player from my Nav V media player.
    By file, I mean place one MP3 song on your internal drive. My Nav V wouldn't recognize MP3's on my SD card until I did this.

    MY old Sena SMH10 and Nav V would occasionally drop the Bluetooth connectivity which was frustrating .

    Try doing a factory and/or hard reset of the Nav V and see if this fixes your issue.

    My Nav V is 7 years old and has begun to occasionally freeze while navigating a route.
    Nav V's have been more reliable than the Nav VI's

    Andy

  5. #5
    Registered User
    Join Date
    Jan 2015
    Location
    Pickering, ON, Canada
    Posts
    132
    So, Garmin support suggested I get a different SD card and format it and try again. Exactly the same outcome. I have tried a hard reset and it doesn't seem to have made a difference.

    Maybe, now that I've given them feedback on their first suggestion, Garmin support will come up with something. But it is annoying.
    Bob
    2014 R1200RT
    2017 R1200 GSA

  6. #6
    Registered User
    Join Date
    Jun 2015
    Location
    College Station, TX
    Posts
    86
    Quote Originally Posted by bobs_one View Post
    Thanks Ken. My setup is pretty much the same - but I have to have an MP3 folder on the internal memory in addition to the the MP3 folder on the external memory, or the Media Player gives me an error message saying that I need to put my songs into the MP3 folder (even though I have). And, even more problematic is the fact that it always crashes the NAV V the second time I try to run the media player (after restarting the motorcycle).

    It works well enough for me to play music, but it is annoying to have the unit reboot every second time.
    Is your GPS software/firmware up to date? Here is some of the version info from mine:

    Hardware Version: V6 SA3 8GB 128MB MO PR BN
    Software Version: 3.50
    BMW Motorrad: 10.00
    GPS Firmware: 3.05.14

    Ken
    2015 R1200GS

Similar Threads

  1. Help with nav 4 media player over bike's speakers 2012 R1200RT
    By chrismiii in forum Hexheads/Camheads
    Replies: 2
    Last Post: 05-02-2013, 05:22 PM
  2. MP3 Player Recs?
    By Shell4747 in forum Gear
    Replies: 17
    Last Post: 07-04-2008, 01:05 PM
  3. Worthless CD Player
    By podsobinski in forum Hexheads/Camheads
    Replies: 14
    Last Post: 01-13-2008, 06:48 PM
  4. R1200RT CD Player
    By eric81 in forum Hexheads/Camheads
    Replies: 8
    Last Post: 07-11-2007, 01:42 PM
  5. CD Player
    By donscoin in forum Flying Brick K-bikes
    Replies: 7
    Last Post: 12-28-2006, 04:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •