Page 2 of 2 FirstFirst 1 2
Results 16 to 19 of 19

Thread: 2012 RT Intermittent Stuttering/surging Running Problems

  1. #16
    Registered User bicyclenut's Avatar
    Join Date
    Jul 2016
    Location
    Sugar Grove, IL
    Posts
    73
    On my 2010 RT I had a intermittent misfire/stumble. I would be riding down the expressway on cruise, at a steady speed or accelerating and there would just be a brief stumble or feeling of a brief misfire. It was VERY intermittent and I saw no errors when I checked for codes with my GS-911. I tried injector cleaner and had synced the throttle body. Had about 60K. I replaced all the coils and spark plugs at the same time and it resolved the problem. I had done research on this and this seemed to be one of the causes of this and I finally decided to try it and that was the fix for me.

    This is a source of BMW stick coils that would be an alternative to a BMW dealer:

    https://www.euromotoelectrics.com/category-s/1754.htm
    2010 BMW R1200RT
    2014 BMW C650GT (sold)
    MOA # 208387

  2. #17
    Quote Originally Posted by drneo66 View Post
    Unlikely you picked up that much more water, but it depends on where you were traveling.

    I assume you have enough slack in the throttle cable? All the vacuum hoses are connected correctly?

    Did you reset the throttle positioning sensors when you reconnected the battery? (Turn ignition to on but don't start bike. Slowly open the throttle wide open then closed, open/closed a total of three times)

    Bad coils could be an issue, but I'd assume it would be unlikely that several would go bad. I think the secondary coil is used during lower RPMS and then the primary takes over at higher?? You could swap/reseat them just in case.

    Have a friend with a MotoScan or GS911?
    Thanks

    No friend with a GS911. I thought about buying one. I did do the TPS reset. Bike did idle fine after that. Rode it the next day and is stuttered while running high RPM's.
    So I just took it home before it got worse.

    Discussed with the Dealer and they said this is not a normal issue and will have to start testing all the different systems. This is above my knowledge level on this.

  3. #18
    Quote Originally Posted by lkraus View Post
    All four coils are in use at low rpm. As rpms rise, the timing on the lower coils shifts nearly 180, and they don't contribute much to combustion. A loose coil wire on a primary coil produced intermittent hesitation and stumbling above ~3500 rpm on my RT, especially under acceleration. It ran normally at lower rpm or under light load. One way to check would be to disconnect a suspect coil, if the the bike runs worse that coil was good, if there is no change you found the problem.

    I have not suggested coil trouble because apparently the problem has occurred while starting from a stop and required high rpm to get moving, which is quite different than the trouble I experienced.
    Thanks
    The first it happened was at high RPMs and when I parked it it was also doing it at high RPM's. I may check the coils before it go into the dealer, but I think I will take it there because I do not want to have this happen while I am out away from the house.

  4. #19
    Quote Originally Posted by bicyclenut View Post
    On my 2010 RT I had a intermittent misfire/stumble. I would be riding down the expressway on cruise, at a steady speed or accelerating and there would just be a brief stumble or feeling of a brief misfire. It was VERY intermittent and I saw no errors when I checked for codes with my GS-911. I tried injector cleaner and had synced the throttle body. Had about 60K. I replaced all the coils and spark plugs at the same time and it resolved the problem. I had done research on this and this seemed to be one of the causes of this and I finally decided to try it and that was the fix for me.

    This is a source of BMW stick coils that would be an alternative to a BMW dealer:

    https://www.euromotoelectrics.com/category-s/1754.htm
    Did you get the coils from the dealer or from the source you sent? If you got them from the source, were there any issues? The savings is a couple hundred dollars.

    I did test two coils last night and one is weak. I am thinking that I should just replace all 4 to be safe.

    Thanks

Similar Threads

  1. 2008 R1200RT - Intermittent Rough Running
    By ExGMan in forum Hexheads/Camheads
    Replies: 10
    Last Post: 08-13-2014, 04:10 PM
  2. intermittent rough running; hot cat
    By MinnesotaRik in forum Oilheads
    Replies: 4
    Last Post: 07-21-2014, 10:26 PM
  3. Intermittent Very Rough Running
    By richardak in forum Airheads
    Replies: 19
    Last Post: 11-25-2013, 10:25 PM
  4. 2012 GSA intermittent stalling
    By OfficerImpersonator in forum Hexheads/Camheads
    Replies: 4
    Last Post: 05-31-2013, 09:34 PM
  5. Intermittent Starting Problems 1150RT
    By moenko in forum Oilheads
    Replies: 10
    Last Post: 06-04-2012, 10:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •