Results 1 to 7 of 7

Thread: Bike dies at stop lights

  1. #1
    TX Rider
    Join Date
    May 2006
    Location
    Richmond, KY
    Posts
    6

    Bike dies at stop lights

    Have a 2007 F650 Dakar. When I come to a stop, RPMS drop to around 1,100, flutters for a few seconds, then drops to 0 and the bike dies. Can restart and go on, but happens at every stop unless I manually keep the revs up? New gas and same problem, so not fuel related. Ideas?

  2. #2

    More information

    Miles on bike? Service history complete? Any past problems with electric or fuel injection? Crashed in the past? Owned since new? GS 911?

  3. #3
    Registered User Guenther's Avatar
    Join Date
    Jan 2007
    Location
    Colorado Springs, CO
    Posts
    831
    There is a procedure to calibrate the throttle position:

    "Ignition on (don't start it) twist the throttle slowly from full off to full on and back three times, ignition off. Then start as normal without twisting the throttle..."

    ...from https://www.f650.co.uk...Throttle-rxeset-procedure

    /Guenther
    2017 F700GS - I wish she had a drive shaft

  4. #4

    Stalling problem solved g650gs

    Hi all, I was having the same problem this week with the 2015 g650gs I bought recently. Every time I pulled in the clutch, the bike was stalling. The technique mentioned in this thread worked perfectly:

    1. Turn off bike if running
    2. Turn key to on position but do not start
    3. Twist throttle three times
    4. Press start button without touching throttle

    After trying this today, the idle returned to normal and bike did not stall.

    Brilliant, thank you all

  5. #5
    Registered User
    Join Date
    May 2020
    Location
    Londonderry, VT
    Posts
    7

    additional info

    Hi there,

    I have also recently experienced similar issues with my 2009 G650GS, my bike has just over 13k miles. I experienced this at one point and thought it was fuel level, had my wife deliver me some fuel and it only took about 3 gal. After filling up all good, changed to high octane fuel thinking that may be better for the engine, then experienced the problem again. But this time I clocked miles at 178 miles since full and pulled into fill up and now fine again.

    Could there be a problem with the fuel pump, hose not sitting low enough to get me to the reserve level and actually turn on the low fuel light? I will be monitoring the 178 ,mile mark again to perhaps avoid the issue but nerve racking nonetheless.

    Any ideas?

    Thanks

  6. #6
    Fortis Fortuna Adiuvat Omega Man's Avatar
    Join Date
    Jan 2010
    Location
    Mansfield,MA
    Posts
    15,616
    Quote Originally Posted by tkajah4166 View Post
    Hi there,

    I have also recently experienced similar issues with my 2009 G650GS, my bike has just over 13k miles. I experienced this at one point and thought it was fuel level, had my wife deliver me some fuel and it only took about 3 gal. After filling up all good, changed to high octane fuel thinking that may be better for the engine, then experienced the problem again. But this time I clocked miles at 178 miles since full and pulled into fill up and now fine again.

    Could there be a problem with the fuel pump, hose not sitting low enough to get me to the reserve level and actually turn on the low fuel light? I will be monitoring the 178 ,mile mark again to perhaps avoid the issue but nerve racking nonetheless.

    Any ideas?

    Thanks
    I just did spark plugs on my ‘09 F800GS. I had to dig in deep to do it. There are 2 hoses that seems to have something to do with the idle that were in bad shape on all 4 ends.
    Perhaps with the same vintage you have something similar going on.
    The hoses were called “idle actuator” hoses. I did a work-around and since ordered the set from MAX.
    The bike would just shut off at idle but would instantly restart.
    Good luck.
    OM
    "You can do good or you can do well. Sooner or later they make you choose." MI5
    Mod Squad
    2009 F800GS 1994 TW200

  7. #7
    Registered User
    Join Date
    May 2020
    Location
    Londonderry, VT
    Posts
    7
    Quote Originally Posted by Omega Man View Post
    I just did spark plugs on my ‘09 F800GS. I had to dig in deep to do it. There are 2 hoses that seems to have something to do with the idle that were in bad shape on all 4 ends.
    Perhaps with the same vintage you have something similar going on.
    The hoses were called “idle actuator” hoses. I did a work-around and since ordered the set from MAX.
    The bike would just shut off at idle but would instantly restart.
    Good luck.
    OM
    Thanks, I will look into that for sure. I just don't understand how everything is fine for the 178+/- miles and then it decides to act up.

Similar Threads

  1. 2005 R 1200 GS dies when downshifting to a stop
    By chasmrider in forum Hexheads/Camheads
    Replies: 10
    Last Post: 05-31-2016, 10:54 PM
  2. 2014 RT Dies at stop light
    By skupnjak in forum Wetheads
    Replies: 5
    Last Post: 07-24-2015, 12:33 AM
  3. Top Case with LED stop lights.
    By 14RT_rider in forum Oilheads
    Replies: 3
    Last Post: 11-05-2009, 07:47 PM
  4. LED Tail/Stop Lights
    By CG2005 in forum Thumpers - F & G bikes
    Replies: 2
    Last Post: 09-08-2006, 04:05 PM
  5. stop lights
    By acehosedme in forum Flying Brick K-bikes
    Replies: 4
    Last Post: 10-09-2003, 04:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •