Results 1 to 3 of 3

Thread: Radio/CD player not working on my K1200LT

  1. #1
    Registered User
    Join Date
    Mar 2007
    Location
    Colorado Springs, CO
    Posts
    16

    Radio/CD player not working on my K1200LT

    The radio/cd player is not working on my 1999 K1200LT. I have power to the unit, it lights up but no sound. I removed the trunk with the rear speakers, would that cause the unit not to work? All other electrics are working on the bike. Thanks, Dave

  2. #2
    Quote Originally Posted by djcondie View Post
    The radio/cd player is not working on my 1999 K1200LT. I have power to the unit, it lights up but no sound. I removed the trunk with the rear speakers, would that cause the unit not to work? All other electrics are working on the bike. Thanks, Dave
    Hook the trunk/speakers back up and see if it then works. I am betting it will.
    Paul Glaves - "Big Bend", Texas U.S.A
    "The greatest challenge to any thinker is stating the problem in a way that will allow a solution." - Bertrand Russell
    http://web.bigbend.net/~glaves/

  3. #3
    Registered User
    Join Date
    Mar 2007
    Location
    Colorado Springs, CO
    Posts
    16
    I will try that, thanks

Similar Threads

  1. Radio/CD not working 2006 R1200RT SE
    By aussiebob in forum Hexheads/Camheads
    Replies: 1
    Last Post: 01-27-2018, 02:26 PM
  2. Is the CD player the radio?
    By greggsnider in forum Hexheads/Camheads
    Replies: 0
    Last Post: 06-04-2012, 08:14 PM
  3. R 1200 RT Radio not working
    By Nick900 in forum Hexheads/Camheads
    Replies: 1
    Last Post: 09-10-2011, 12:06 PM
  4. K1200lt radio
    By charlesf in forum Flying Brick K-bikes
    Replies: 0
    Last Post: 03-16-2010, 04:25 AM
  5. Modifying OEM CD player & radio
    By jstrube in forum Hexheads/Camheads
    Replies: 6
    Last Post: 02-24-2010, 10:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •