Results 1 to 3 of 3

Thread: Troubles with my 04 R1150RT

  1. #1

    Troubles with my 04 R1150RT

    Hello, Looking for some words of wisdom on the problem I had today. Yesterday we rode 270 miles without a hitch, today after about 60 miles my R1150 RT had what I'd call a total electrical failure, in traffic. After getting a ride home, we tested the battery (13V), check the kill switch and looked over the fuses (all appear good). Having read about faulty wires under tiedown points (the chassis has about 100K miles) I wiggled all the wires I could and turned the bars both directions to the stops. Still no indicator lights. Any ideas on fixing this one??

  2. #2
    Pepperfool GSAddict's Avatar
    Join Date
    Feb 2008
    Location
    Sechelt, British Columbia
    Posts
    3,311
    Follow the ignition switch harness to the orange connector - left of the speedo cluster
    Is there 12v+ on the red wire?
    Next
    Is there 12v+ on the green wire when the ignition is turned on?
    '
    Ufda happens..........

    Need your R11xx Hall sensor rewired? PM me.

  3. #3

    Elec.

    Quote Originally Posted by trapboy View Post
    Hello, Looking for some words of wisdom on the problem I had today. Yesterday we rode 270 miles without a hitch, today after about 60 miles my R1150 RT had what I'd call a total electrical failure, in traffic. After getting a ride home, we tested the battery (13V), check the kill switch and looked over the fuses (all appear good). Having read about faulty wires under tie-down points (the chassis has about 100K miles) I wiggled all the wires I could and turned the bars both directions to the stops. Still no indicator lights. Any ideas on fixing this one??
    I'm betting that your ignition switch harness is failing. BMW tied the harness way too tight (wire ties) at the factory so that when moving the handlebars, the harness flexes and weakens right where it plugs into the switch.

    It happened to me about 10 years ago and I had to repair the frayed hot wire (only a few strands were left) and then tied it off very, very loosely. The goal is to not have the connection right at the ignition switch flexing/twisting every time the handlebar is moved off center.

    RPG

Similar Threads

  1. speedometer troubles
    By apt13 in forum Airheads
    Replies: 10
    Last Post: 03-26-2011, 03:12 AM
  2. GPS Troubles
    By IRONMAN in forum Campfire
    Replies: 0
    Last Post: 04-01-2007, 11:22 PM
  3. GPS V Troubles
    By 2whelman in forum Gear
    Replies: 2
    Last Post: 01-04-2006, 01:38 PM
  4. Headlight Troubles R1150rt
    By MPATROVSKY in forum Oilheads
    Replies: 7
    Last Post: 08-09-2005, 03:18 PM
  5. Registration troubles.
    By IMARTIN in forum Rally Forum
    Replies: 3
    Last Post: 06-01-2004, 09:20 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •