Results 1 to 2 of 2

Thread: 2015 F 650 GS Electrical Problems

  1. #1
    Registered User
    Join Date
    Jun 2006
    Location
    Bonney Lake, WA
    Posts
    18

    2015 F 650 GS Electrical Problems

    Hello,

    I just bought this 2015 650 GS with only 110 miles on the odometer. Although low mileage is usually a good thing, in this case it had been sitting idle for about 5 years, which can cause its own set of problems. So I wasn't surprised to find it had a couple of electrical gremlins like the horn, headlight and heated grips not working. The headlight could be just a bulb problem, but neither the low nor high beams come on and I am a little skeptical that both filaments would be burned out just from sitting so long with no use. I would love to find that all of those problems are related to a common component, controller or corroded ground lead. I checked all of the fuses and they seem to be good. I also disconnected then reconnected every wire I could see that was routed through a connector in the hope that I would be able to scrape off any corrosion that might have been on any of its pins. I'm also curious as to whether there is an oil pressure sensor that could have failed, but I don't know if those items would require oil pressure and have no idea where to look for the sensor if it does. An owner's manual didn't come with the bike, although the consignment sales person who sold the bike to me is supposed to contact the owner to see if she has it, but I haven't heard from him yet.

    Other than those components, the bike seems to start and run okay. Any help that anyone can provide will be greatly appreciated.

    Thanks,

    Jim Hawks

  2. #2
    Look thoroughly and carefully for rodent damage to the wiring.
    Paul Glaves - "Big Bend", Texas U.S.A
    "The greatest challenge to any thinker is stating the problem in a way that will allow a solution." - Bertrand Russell
    http://web.bigbend.net/~glaves/

Similar Threads

  1. Electrical problems converting 94 RT into RS !
    By sfletcher04 in forum Airheads
    Replies: 2
    Last Post: 08-14-2014, 12:09 AM
  2. Need help, 05 1200GS with electrical problems
    By espressoforyou in forum Hexheads/Camheads
    Replies: 4
    Last Post: 09-07-2012, 01:42 PM
  3. '08 K12S Electrical Problems
    By GREGFUESS in forum Wedge K-bikes
    Replies: 3
    Last Post: 10-05-2009, 07:15 PM
  4. electrical problems
    By marbil in forum Oilheads
    Replies: 4
    Last Post: 09-28-2009, 09:23 PM
  5. Electrical problems
    By DDHR1150RT in forum Oilheads
    Replies: 2
    Last Post: 08-20-2003, 12:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •