Results 1 to 3 of 3

Thread: Tire Pressure Sensor not working after tire change 2012 F650GS

  1. #1

    Tire Pressure Sensor not working after tire change 2012 F650GS

    I had new tires put on my 2012 F650GS and the front TPS isnít working now. The rear is fine. Does anyone know what I should be looking for to fix it?

  2. #2
    Debbie's Servant Lee's Avatar
    Join Date
    May 2003
    Location
    SW Iowa
    Posts
    7,504
    The TPM sensor may have been damaged during the tire change.
    You might have to remove the tire to look.
    If it was the original TPM the battery may have died.
    Welcome to the forum.
    Lee
    2016 R1200RS
    MOA # 30878
    Past BMW Bikes: 2011 K1300S, 2003 K1200RS, 1991 K75S, 1987 K75T, 1984 R100RT

  3. #3

    Thanks for the quick reply

    Thanks for the quick reply. Thatís what Iím afraid of, given the cost of a new unit. I may wait for the next tire change.

Similar Threads

  1. Good source for tire pressure sensor?
    By irish in forum Wetheads
    Replies: 15
    Last Post: 09-16-2018, 12:29 AM
  2. tire pressure sensor
    By dpmonk in forum Hexheads/Camheads
    Replies: 8
    Last Post: 09-05-2018, 02:54 AM
  3. Tire Pressure Sensor - 2008 R1200RT
    By ItsPhilD in forum Hexheads/Camheads
    Replies: 4
    Last Post: 06-04-2014, 11:32 PM
  4. Tire pressure sensor
    By 30300 in forum Hexheads/Camheads
    Replies: 4
    Last Post: 05-16-2010, 01:53 PM
  5. F650GS tire pressure???
    By beeryboats in forum Thumpers - F & G bikes
    Replies: 13
    Last Post: 10-24-2009, 08:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •