Results 1 to 4 of 4

Thread: 2010 F650GS: bike starts, but screen is blank

  1. #1
    MotoFly
    Join Date
    Jun 2009
    Location
    South Florida
    Posts
    25

    2010 F650GS: bike starts, but screen is blank

    We have cool weather here in Miami, so I was just about to go for a ride. The bike started right up--I didn't have it on a charger since my last ride--but the screen is blank. Restarted, etc; same thing. Any troubleshooting ideas welcome-- Tom

  2. #2
    Registered User
    Join Date
    Mar 2003
    Location
    Lanark County near Ottawa ON
    Posts
    252
    https://f800riders.org/forum/showthr...ing-off-and-on

    Some ideas in the link.

    Sent from my SM-T813 using Tapatalk

  3. #3
    Registered User
    Join Date
    Mar 2003
    Location
    Lanark County near Ottawa ON
    Posts
    252
    https://advrider.com/f/threads/f800g...uster.1060506/

    Another possibility.

    Sent from my SM-T813 using Tapatalk

  4. #4
    MotoFly
    Join Date
    Jun 2009
    Location
    South Florida
    Posts
    25
    Thanks, RadioFlyer. I checked the battery--13.2--and suspect a failing starter switch; maybe due to moisture. Tom

Similar Threads

  1. 2010 RT - After market screen advice
    By stinkypete in forum Hexheads/Camheads
    Replies: 9
    Last Post: 01-27-2019, 12:45 PM
  2. Only Starts in Neutral- 2010 RT
    By etiennelau in forum Hexheads/Camheads
    Replies: 16
    Last Post: 03-12-2016, 10:47 PM
  3. tach died,bike starts in gear
    By louieskretas in forum Oilheads
    Replies: 8
    Last Post: 08-07-2011, 07:38 PM
  4. bike starts without choke
    By nhlkats in forum Airheads
    Replies: 2
    Last Post: 12-12-2006, 09:51 PM
  5. wind screen for f650gs
    By farzadthebarber in forum Thumpers - F & G bikes
    Replies: 5
    Last Post: 04-11-2005, 05:06 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •