Page 5 of 5 FirstFirst ... 3 4 5
Results 61 to 69 of 69

Thread: Nav V stuck in Year 2000

  1. #61
    Registered User
    Join Date
    Feb 2015
    Location
    Seattle
    Posts
    42

    And another Y2K Nav V

    Quote Originally Posted by sleeper View Post
    Don't wait for Garmin. Contact them.
    I finally saw the email link on Garmin's support page and sent in a description of the problem this past weekend. Their reply was fast and the message was succinct "Verify your shipping address and we will send you an RMA to exchange the unit". I confirmed my address, got the RMA and shipping instructions within 2 hours. My funky date unit is going back and I expect to receive a replacement unit within a week.

    I bet there are a more "broken" units out there not known to their owners. I never use or refer to my bike's date. And I only noticed the problem when the GPS color mode did not switch after sunset. I would suggest anyone with a Nav V go in to the World Clock app on their unit and check out the time displayed there. That is the only place on the Nav V that I could find the date displayed. If the date is correct, count yourself lucky.

    I am guessing we will not see any firmware fix to this problem. Their most practical fix is to replace the few units that actually contact them about the problem. I hope that helps you out with how you proceed.
    Like you, I noticed the day to night function wasn't working on my Nav V. I romantically thought it was because it gets dark at 5pm at this time of year in Seattle. Upon further review, and not too much of a search effort, here I am. My Nav V is from a 2016 R1200RT, only two-and-a-half years old. I've sent Garmin an email.

  2. #62
    Registered User
    Join Date
    May 2015
    Location
    South Central PA
    Posts
    78
    Quote Originally Posted by WWeldin View Post
    Gotta get back in time!! (ala Huey Lewis and The News)
    Back to the Future WWeldin. Maybe .... like.... 2112?
    2015 R1200GSA

  3. #63
    Update released today seems to have fixed the issue. Quick 5 minute install via Garmin Express- version 3.5 on completion.

  4. #64
    Registered User
    Join Date
    Jun 2016
    Location
    Charlottesville, VA area
    Posts
    41
    Quote Originally Posted by grcrowell View Post
    Update released today seems to have fixed the issue. Quick 5 minute install via Garmin Express- version 3.5 on completion.
    Apparently the issue has been resolved, although I haven't installed the update yet.

    Couple of thoughts- first, kudos to Garmin for responding to this. They could have easily ignored this given that the NAV5 population out there probably isn't close to their largest business segment.

    Second, I have to think that having our MOA rep- ExGman- make the effort to communicate with Garmin on the issue as well as the many NAV5 owners that took the time to contact Garmin helped keep this on the front burner.

    Looks like I'm good for another 1,024 weeks...

  5. #65
    Debbie's Servant Lee's Avatar
    Join Date
    May 2003
    Location
    SW Iowa
    Posts
    6,585
    Quote Originally Posted by grcrowell View Post
    Update released today seems to have fixed the issue. Quick 5 minute install via Garmin Express- version 3.5 on completion.
    I did the update on both of our units and it fixed the date problem.
    Lee
    2016 R1200RS
    MOA # 30878
    Past BMW Bikes: 2011 K1300S, 2003 K1200RS, 1991 K75S, 1987 K75T, 1984 R100RT

  6. #66
    Registered User
    Join Date
    Jul 2016
    Location
    Southeastern VA
    Posts
    154
    Quote Originally Posted by grcrowell View Post
    Update released today seems to have fixed the issue. Quick 5 minute install via Garmin Express- version 3.5 on completion.
    Quick update to load (by Garmin standards). Works like a champ!


    Sent from my iPad using Tapatalk

  7. #67
    Registered User
    Join Date
    Sep 2015
    Location
    Birmingham, AL
    Posts
    239
    The update fixed my Nav V problem. Does any one know if this problem affected the Garmin Montana 650? Or any other Garmin units? I've looked at all the settings on my Montana, and all looks good, but I want to be sure I'm not missing something.

    Thanks!
    J Goertz
    BMW MOAL
    2015 BMW R1200RT
    2012 Triumph Bonneville SE

  8. #68
    Debbie's Servant Lee's Avatar
    Join Date
    May 2003
    Location
    SW Iowa
    Posts
    6,585
    Quote Originally Posted by jgoertz View Post
    The update fixed my Nav V problem. Does any one know if this problem affected the Garmin Montana 650? Or any other Garmin units? I've looked at all the settings on my Montana, and all looks good, but I want to be sure I'm not missing something.

    Thanks!
    Most of the posts I read said it affected the NavV.
    All you have to do to check is look at your World Clock on the unit.
    On a Nav you get to World Clock after opening Apps.
    Lee
    2016 R1200RS
    MOA # 30878
    Past BMW Bikes: 2011 K1300S, 2003 K1200RS, 1991 K75S, 1987 K75T, 1984 R100RT

  9. #69
    Debbie's Servant Lee's Avatar
    Join Date
    May 2003
    Location
    SW Iowa
    Posts
    6,585
    As promised I did receive a email from Garmin tonight letting me know a fix was available in Garmin Express.
    Lee
    2016 R1200RS
    MOA # 30878
    Past BMW Bikes: 2011 K1300S, 2003 K1200RS, 1991 K75S, 1987 K75T, 1984 R100RT

Similar Threads

  1. R1100RT Improvemnts and changes from Year to Year
    By oldcarman in forum Oilheads
    Replies: 3
    Last Post: 07-31-2018, 05:34 PM
  2. Stuck for another year.
    By helmut_head in forum Airheads
    Replies: 1
    Last Post: 02-20-2012, 04:22 PM
  3. r100 year to year changes
    By atlbmw in forum Airheads
    Replies: 6
    Last Post: 08-05-2009, 03:44 PM
  4. Stuck oil pan
    By DS74BMW in forum Airheads
    Replies: 5
    Last Post: 07-13-2009, 02:22 AM
  5. Help-stuck gas cap
    By alans1959 in forum Airheads
    Replies: 9
    Last Post: 08-04-2007, 07:44 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •