Results 1 to 4 of 4

Thread: Navigator V - No speed or heading while in cradle

  1. #1

    Navigator V - No speed or heading while in cradle

    Hi all,

    The past few weeks I've been having a weird problem with my Navigator V on my '14 R1200RT... While in the cradle on the bike, the GPS charges just fine (except when the unit randomly decides it's been removed from the cradle while I'm going down the road) but it doesn't think I'm moving (the speed field on the display shows a constant 0) and it doesn't have a heading either, thinking I'm always facing 0 degrees. The unit does, however, have my correct location at all times...

    I've tried removing and re-seating the unit tons of times with no real success. A factory reset didn't do anything. I haven't pulled my dash apart yet to check if the wiring for the GPS connector has gone bad, was hoping someone might have seen this before and have some insight.

  2. #2
    Registered User patm's Avatar
    Join Date
    Mar 2016
    Location
    Montreal, QC
    Posts
    376
    Just a thought, have you tried cleaning the cradle connections?
    Pat

    Ride Safe!
    '16 RT

  3. #3
    Registered User
    Join Date
    Aug 2016
    Location
    Tampa, Florida
    Posts
    29
    Second that. Try contact cleaner. A few years ago my Nav V was acting funny. I cleaned the contacts and it took care of the problem.
    Bob, MOA#143234
    2014 R1200RT

  4. #4

    Knew it had to be something simple!

    Yep, you guys were spot on, I don't know why I didn't even think of this - a spritz or two of contact cleaner on both the GPS and bike pins and it's working like new again. I even managed to get it to sync with my laptop finally courtesy of a cheap USB 2.0 adaptor on Amazon, to boot! Thanks again!

Similar Threads

  1. Navigator III Cradle Connection
    By Kentuckyblue in forum Gear
    Replies: 6
    Last Post: 10-04-2011, 03:05 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •