Results 1 to 14 of 14

Thread: macOS Catalina issues with Garmin Nav devices DATA ACCESS

  1. #1

    macOS Catalina issues with Garmin Nav devices DATA ACCESS

    Recently, (10/10/19) I upgraded my MacBook Pro (Mid 2015) to macOS Catalina 10.15

    I was adapting to lots of slight differences in the operating system, but the one that caused me troubles was accessing my Garmin Nav VI in both Garmin Express and Garmin BaseCamp.

    When apps/devices that could be considered a security risk by allowing that app/device to have access to your computers files and folders is accessed for the first time, the Catalina OS displays a small Pop-up box with a question of whether or not you want to allow that app/device to have access to your computer files.

    I see the general philosophy Apple has blended into this new version of the OS to protect our privacy and security, but I fell victim to the nice sense of security and was unaware of how this would affect my interface with one of my most used devices...namely my BMW Nav VI.

    I spent a full day going thru all kinds of WWW derived "fixes" trying to gain control of my GPS, and didn't find an answer that worked until I actually drilled down deep enough on Garmin's website to find the exact solution I needed.

    My issue was that I could see both the storage devices of my Nav VI, internal memory and microSD card in the Mac Finder, but could not get the device to be recognized by either Garmin Express or BaseCamp to update the Nav or transfer routes to my device.

    By allowing access for BOTH Garmin BaseCamp and Garmin Express in your Security/Privacy Settings, I now have normal access to my GPS to work as before.

    Hope this saves someone some headaches!

  2. #2
    Registered User kevinsclo's Avatar
    Join Date
    Sep 2013
    Toronto, Canada
    Yes, Apple really locks down all the app permissions with Catalina.

    I was caught off guard after the upgrade as well.

  3. #3
    Fortis Fortuna Adiuvat Omega Man's Avatar
    Join Date
    Jan 2010
    Great information guys 👍
    "You can do good or you can do well. Sooner or later they make you choose." MI5
    Mod Squad
    2009 F800GS 1994 TW200

  4. #4
    Registered User stooie's Avatar
    Join Date
    Aug 2018
    Salem, OR


    I just upgraded my iMac to Catalina yesterday. It's good to be aware of the issue and have a path forward.

    I've never been very happy with Base Camp. What's the opposite of "user friendly"? I would characterize Base Camp as "user hostile".

    At the advice of one of the guys at the local dealership, I've tried and have better luck with it. I'll have to try it with the new OS and see if it has these issues.

    UPDATE OCT 18: Garmin Express worked fine with no fiddling required on my iMac. Best possible outcome for me.

    Thanks again.

    Ride long and prosper.
    Last edited by stooie; 10-18-2019 at 04:00 PM.
    Bob Stewart
    Salem, OR

    2018 RT

  5. #5
    Registered User RIDERR1150GSADV's Avatar
    Join Date
    Apr 2017
    Thank you for that info, as I just installed Catalina on my MacBook Air...
    MOA # 108516
    Current ride 2018 R1200 GSA Triple Black
    Past rides '04 R1150RT, '05 K1200LT, '06 R1150GSA, Ď17 R1200RT

  6. #6
    DesmoDerek desmoderek's Avatar
    Join Date
    Aug 2016
    Indianapolis, IN
    Good to know1 Thanks!
    MOA # 210167
    Mars Red RT White Multistrada 1200 Enduro Bonbler Black i.e. Bonneville Black Scrambler (carb)

  7. #7
    Boxflyer - Thanks for the post !!!!

  8. #8
    Quote Originally Posted by dfisher1 View Post
    Boxflyer - Thanks for the post !!!!
    I second dfisher1ís comment. I havenít upgraded my OS yet but will soon. This info will surely save possible upcoming frustration.


  9. #9
    Registered User crucian's Avatar
    Join Date
    Jun 2017
    St. Croix, Virgin Islands
    Apple went to 64 bit processing with OS Snow Leopard a good while back and "warned" application providers that at some point the OS would no longer support 32 bit programs. That "some point" is now with Catalina. Why 64 bit? 32 bit applications limit the amount of computer memory available to process data at 4Mb. There are many applications that perform on a different plane with the 64 bit ability to utilize more memory.

    Criticize them if you will but Apple places no stock in application providers that for whatever reason failed to upgrade their code to the 64bit environment. See ya........

    In addition to this, as mentioned, Apple is going to greater and greater lengths to protect privacy and security. Is confirming that you actually want to run an application and allow it access to your file system too much to handle? IMHO, no it is not. As far as Garmin goes, I use Garmin and respect the company but at times I'm convinced there's something in the water out there in Olathe, Kansas. It seems at times it's the Garmin way or the highway when it is painfully obvious that Garmin would do well to conform to well established standards and make life easier for every one of its customers. QC? how could I exit without mentioning the completely unacceptable failure of Nav VI units due to Ghost Touch over a long period of production in a unit that retails for a thousand dollars.

  10. #10
    Registered User
    Join Date
    Jan 2017
    Bothell, WA - USA
    I can't help but respond. This is not a Garmin issue at all, whether you like their products or not, and it's not a 64 vs. 32 bit issue either as someone suggested. It's a matter of increased data security built into all new(er) versions of operating systems, and sounds like Apple is finally acknowledging increased risks that target them like Windows OS users have dealt with for a long time.

    When you or existing programs attempt to download a new or upgraded executable program like Garmin Express or Basecamp (as simple examples), you are now asked if you trust it doing so.

    Simply put, the OP did you Apple users who responded a service by letting you know what it took for him to download these two updated third-party products under the latest Apple OS. Now you understand how to respond. Get used to it, and don't blame the app providers.

  11. #11
    Rainman48 said...
    "Simply put, the OP did you Apple users who responded a service by letting you know what it took for him to download these two updated third-party products under the latest Apple OS. Now you understand how to respond. Get used to it, and don't blame the app providers."

    Another issue that can be solved, is getting some of your legacy APPS to work NOW while waiting for developers to revise their code to comply with Apple's current security policies.

    My work around for this issue for the time being, since I still use just one platform/machine (MacBook) to do all my computer work is this...

    A couple of years ago, when I first got a GS-911 and needed to use the Windows OS, I purchased an emulator, Parallels, to run Windows within my MacOS.

    Now, besides being able to seamlessly jump in and out of my Windows apps, (like GS-911 and my portable DVD player with my Windows based Repair and Service Data disk to copy/paste/print), I have installed an additional complete Operating System in the form of Mac OS 10.14.6, last OS before upgrading to Catalina.

    Now I can still have access to any of my apps that appear with a grey "circle with the slash", general prohibition symbol, by just installing them in my Parallels version of MacOS Mojave.

    Another program that I doubt will ever have developer support to update it to 64bit is JaVaWa, that allows me to log onto and manipulate all the files on my Garmin GPS devices. These files are sometimes given obscure names, and this program lists essential files and old map files so you can easily remove large map data files to allow installing larger new files all on the devices internal memory vs splitting it up with part of the map residing on an SD card.

    I made an informed decision about upgrading to the 64bit Catalina OS, and am able to still work with all my old 32bit apps in Mojave like's not for everyone, but using an emulator such as Parallels works for me.

  12. #12


    Thanks for this heads up. I just upgraded to Catalina yesterday on my Mac Book Pro. Since I am so computer illiterate, I would have spent days trying to figure this out when I connected my Garmin to Garmin Express. Excellent information.

  13. #13
    Registered User roger 04 rt's Avatar
    Join Date
    Oct 2011
    Florida & Massachusetts
    Thanks for this explanation. I had already updated to Catalina. But I run Windows in Bootcamp on my MAC so maybe I'll just download the PC app and run from Windows. How's that for lazy?

    Can you compare the pros and cons of Bootcamp vs Parallels for the things we're doing?

  14. #14
    Registered User BMW_Ken's Avatar
    Join Date
    Nov 2004
    Kingsport, TN
    The issue appears to be corrected with the Catalina update that became available. Get a popup asking you to allow Garmin Express or Basecamp access to your Garmin data and then all works well. Even updated the software on my NAV VI with Garmin Express.
    Ken Martin
    2011 R1200RT
    Kingsport, TN

Similar Threads

  1. Garmin Mapping Issues??
    By gene36542 in forum Gear
    Replies: 11
    Last Post: 11-28-2012, 06:11 PM
  2. Replies: 15
    Last Post: 11-10-2012, 03:44 AM
  3. data from my garmin 410 forerunner
    By f14rio in forum Gear
    Replies: 0
    Last Post: 05-03-2011, 12:38 PM
  4. Garmin Zumo Battery issues?
    By RT_Riles in forum Gear
    Replies: 10
    Last Post: 09-15-2010, 02:06 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts