Symptom(s) and current remedy

Very low battery charge causing stuck starter relay making three delayed attempts to turn engine when off before battery quickly died.

Replaced relay, inspection of original relay showed no fusing of contacts. It will be my spare.

Replaced 10 year old battery with new. Ran great for 30 mile back country commute home and got a bright battery warning light upon commute-end idle. Increasing RPM would dim light. Started right up the next morning and made return 30 mile trip to shop. Again, got bright warning light upon commute-end idle. With engine off new battery had 12.58 v charge.

Started engine and checked battery voltage at 3000 RPM and it did not move. Tested battery voltage on my other K75C at 12.6 v at rest, and jumped to 13.6 v at 2500 RPM.

It seemed pretty clear the battery was not getting a charge. Removed alternator. Bearing felt good, contacts need cleaning, brush protruding lengths; 1 at 5mm and 1 at 6 mm. (5 mm is the service limit) Brush springs were not binding.

I might have to call around to see if anyone can bench test the alternator. Is it likely that just the brushes need replacing if I cant find anyone local to do the bench test? I have no knowledge of whether the symptoms could indicate a bad rectifier. I already asked one local motorcycle repair veteran for a bench test reference without luck.

Euro Motoclectrics sells a 33 Amp remanufactured Alternator for $179. The entire voltage regulator is $39. I can afford the purchase. I have no need for the 50 Amps on either of my Ks. If I wanted to solder, the brushes are available for $19.50.

Thanks in advance for your suggestions,
Pete