Results 1 to 4 of 4

Thread: Service indicator turned off - how did I do that?

  1. #1
    Registered User
    Join Date
    Aug 2016
    Location
    Kalamazoo MI
    Posts
    57

    Service indicator turned off - how did I do that?

    Hi keepers of knowledge,
    So the other day during a riding break, I was adjusting both my windshield and the suspension with the controls on the handlebars. Then I noticed that the "SERVICE" light on my dash was gone. This is on most the time on my bike as I do much of my own service and only make it to the dealer every other year or so for the whole cat so to speak. I have no idea how I turned the light off. It's back on now. It'll be in the shop later summer for a full service and they will turn it off then again anyway, but I was curious if there was a button/sequence that turned this light off. I did a quick search of the forum but didn't find the answer, also not sure how adequate my search parameters were. Anyone seen this or am I just seeing things?
    Thanks,

    Jerry
    2010 R1200 RT
    Best Regards,
    Jerry Trepanier
    Augusta, MI
    2006 ST1300, 2010 R1200RT

  2. #2
    Registered User Dann's Avatar
    Join Date
    Dec 2013
    Location
    Laval, QC, Canada
    Posts
    408
    AFAIK it can only be turned off by the dealer or a GS-911
    Daniel
    If you can park it, and not turn around to admire it before walking away, you bought the wrong one.
    2007 R1200RT - IBA # 56396

  3. #3
    Registered User ExGMan's Avatar
    Join Date
    Sep 2009
    Location
    Chestnut Hill, MA
    Posts
    1,604
    Oddly enough, I replaced the battery on my 2015 RT yesterday. After buttoning everything up, I fired it up and went for a ride. As soon as I turned on the ignition, the "Service" light came on. It stayed on. After I stopped for some coffee, and started up again, it was off. I sure can't explain it...
    John Gamel - BMW MOA Consumer Liaison
    2015 Ebony Metallic R1200RT
    Watching the sunrise outdoors statistically increases your odds of having a good day. And needing a nap after lunch.

  4. #4
    Debbie's Servant Lee's Avatar
    Join Date
    May 2003
    Location
    SW Iowa
    Posts
    6,045
    Quote Originally Posted by ExGMan View Post
    Oddly enough, I replaced the battery on my 2015 RT yesterday. After buttoning everything up, I fired it up and went for a ride. As soon as I turned on the ignition, the "Service" light came on. It stayed on. After I stopped for some coffee, and started up again, it was off. I sure can't explain it...
    The bike will loose the date and time when the battery is out.
    If you have a BMW Navigator connected it will reset the bike time and date.
    On our bikes it only took a short time for the service light to shut off.
    Lee
    2016 R1200RS
    MOA # 30878
    Past BMW Bikes: 2011 K1300S, 2003 K1200RS, 1991 K75S, 1987 K75T, 1984 R100RT

Similar Threads

  1. The VOID or ‘Turned It Off’
    By CaptRehkopf in forum Ride Reports
    Replies: 0
    Last Post: 10-12-2016, 10:20 PM
  2. Turned key off motor runs on!!!!!
    By Royalbeemer in forum Airheads
    Replies: 6
    Last Post: 08-22-2011, 07:51 PM
  3. New Oil Turned Black
    By Paul_F in forum Flying Brick K-bikes
    Replies: 5
    Last Post: 12-16-2008, 03:32 AM
  4. What is it about newly turned earth?
    By Bud in forum Ride Reports
    Replies: 5
    Last Post: 11-28-2006, 06:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •