Page 2 of 2 FirstFirst 1 2
Results 16 to 17 of 17

Thread: '91 K75S starts but won't keep running, or restart?

  1. #16
    Registered User AntonLargiader's Avatar
    Join Date
    Jul 2004
    Location
    Charlottesville, VA
    Posts
    2,091
    First I would throw new plugs in it just because I'd want everything to be as perfect as possible. It has helped SO many times that it's not worth thinking about whether or not it "should."

    Then check the S-shaped hose and general condition of the rest of the intake stuff.

    How old is the fuel?

    Lastly, I had a problem with a K75 one time where the bike would fire up and immediately die, every time, but it was like half a second rather than three or four. The details are a bit fuzzy but it turned out to be a bad ignition module that would drop power on one pin (to the fuel pump I think) as soon as the engine caught. I think I fixed it by bypassing whatever pin it was. It was a very interesting problem to find. I don't suspect this is your problem but if it turns out that you are losing spark after some engine cranking then you could have something similar going on.
    Anton Largiader 72724
    Tech articles - YouTube
    Virginia Motorrad Werkstatt BMW motorcycle service and repair in central Virginia

  2. #17
    Anton's reply raised a few questions in my mind.
    You checked the plugs for spark at one point. Presumably the bike was in the "will start then quit" mode at that point.
    When the bike is in the "quit and won't restart" mode, do you still have spark?

    I'd give it a test under those conditions, if you haven't already, as lack of spark under those conditions gives you a direction to pursue.

Similar Threads

  1. 87 K75S Quit Running
    By lostandwandering in forum Flying Brick K-bikes
    Replies: 11
    Last Post: 10-07-2017, 04:02 AM
  2. running rough at high speeds '94 K75S
    By jywatson in forum Flying Brick K-bikes
    Replies: 2
    Last Post: 08-13-2011, 04:04 AM
  3. Question about fueling - 87 K75S Running just fine,
    By lostandwandering in forum Flying Brick K-bikes
    Replies: 2
    Last Post: 11-27-2010, 04:49 AM
  4. K75S running rich
    By millertime93 in forum Flying Brick K-bikes
    Replies: 9
    Last Post: 09-03-2007, 11:47 PM
  5. rebuild.... restart
    By medieval in forum Oilheads
    Replies: 5
    Last Post: 08-08-2006, 05:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •