Results 1 to 3 of 3

Thread: K75S Tach reading funny

  1. #1

    K75S Tach reading funny

    After a short stop of about 10 mins my tach started reading low, I was near the end of my 240 mile trip. Usually at 60 mph the tach will read around 4300 rpm. Well after this stop 60 was about 3400 rpm. It did this for about 15 miles and the went to normal after a really slow sharp turn. What do I need to check to cure this or no cure for it at all. thanks

  2. #2
    Registered User drneo66's Avatar
    Join Date
    Jun 2009
    Location
    Rochester, MN
    Posts
    240
    Both of the wonky tach issues that I've seen in person were because of poor grounding. Double check that your ground cable looks good both at the battery and transmission end. Is this the absolute fix? Probably not, but it's a very simple place to start.
    1995 BMW K75s - 100k and climbing!
    2007 BMW R1200RT - 62k
    2009 BMW G650GS - 22k and ready for Alaska!

  3. #3
    3 Red Bricks
    Join Date
    Jan 2007
    Location
    Pleasanton, Ca.
    Posts
    4,574
    If the problem was ONLY the tach reading incorrectly, and not the engine misfiring, the odds are a bad connection (loose or corroded) to the tach. This includes the positive signal or the ground.

    The instrument cluster (along with several other things) is grounded to the left side of the center frame rail underneath the fuel tank. There is a bolt that bolts to a flange under that frame rail. There are several brown (ground) wires attached there.

    Another possible poor connection could be the plug or plugs (depending on year) on the back of the cluster. On an S, this requires removing the windscreen, front turn signals, headlight and headlight panel, at the least before you can get to the connector.

    Another possibility is poor connection or corrosion on the pins INSIDE the cluster. The tach plugs into a circuit board inside the cluster. Water has been known to cause moisture, condensation and corrosion inside these clusters.

    Another possibility is a circuit board that is going bad inside the cluster. I just got done fixing a speedo that was reading double the proper speed. The fix was a new tach/speedo drive board.




    LONG MAY YOUR BRICK FLY!

    Ride Safe, Ride Far, Ride Often

    Lee Fulton Forum Moderator
    3 Marakesh Red K75Ss
    Mine, Hers, Spare

Similar Threads

  1. 1987 K75S, wonky tach.
    By dieselyoda in forum Flying Brick K-bikes
    Replies: 10
    Last Post: 04-29-2014, 04:30 AM
  2. 1993 K75S (ABS) Speedo/Tach Gremlin
    By GordonOlson in forum Flying Brick K-bikes
    Replies: 5
    Last Post: 06-12-2012, 04:35 PM
  3. Reading Anything?
    By criminaldesign in forum Campfire
    Replies: 122
    Last Post: 10-28-2010, 01:54 PM
  4. K75S Gearbox Telltale Indicator Not Reading Correctly
    By mluckm in forum Flying Brick K-bikes
    Replies: 7
    Last Post: 06-12-2009, 03:15 PM
  5. Funny noises really aren't funny
    By mgalie in forum Flying Brick K-bikes
    Replies: 7
    Last Post: 01-04-2008, 07:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •