Results 1 to 2 of 2

Thread: 99 K1200 LT , ABS lights flashing, noise like a pump running under the seat on the rt

  1. #1

    99 K1200 LT , ABS lights flashing, noise like a pump running under the seat on the rt

    Hi folks. I am in K1200LT hell and I need some advice. After riding a 100 miles on my 99 K1200LT, I stopped at a stop sign. In first gear I pulled on to the road. The bike shuddered, and then my abs lights started flashing alternatively. I stopped at the nearest station to get fuel. I shut the bike off and it sounded like the fans were running. The bike was not running hot. I filled up and took off for home (another 45 miles), and got it home to the garage. I ran it in the garage and shut if off and the sound persisted, but it came from underneath the seat on the right side. The only way I can get it shut off is to pull the ground. With the key on or off when hooked to the battery the sounds persists and the abs lights are still flashing alternatively. Any ideas?

  2. #2
    Registered User GTRider's Avatar
    Join Date
    Apr 2006
    Location
    Nibley, UT USA
    Posts
    877
    Quote Originally Posted by tatonka82 View Post
    Hi folks. I am in K1200LT hell and I need some advice. After riding a 100 miles on my 99 K1200LT, I stopped at a stop sign. In first gear I pulled on to the road. The bike shuddered, and then my abs lights started flashing alternatively. I stopped at the nearest station to get fuel. I shut the bike off and it sounded like the fans were running. The bike was not running hot. I filled up and took off for home (another 45 miles), and got it home to the garage. I ran it in the garage and shut if off and the sound persisted, but it came from underneath the seat on the right side. The only way I can get it shut off is to pull the ground. With the key on or off when hooked to the battery the sounds persists and the abs lights are still flashing alternatively. Any ideas?
    My first hunch would be that you have a stuck microswitch at either the front brake lever or the rear brake pedal. It has been common to see issues with the microswitch from contamination, or with the alignment and adjustment of the rear brake pedal. Check those items and make sure the micro switches are functioning freely, then try connecting the battery again. If you have access to a GS911 that might also give you some fault-codes to check.

    Best,
    DG
    DGerber
    1983 R80ST 1984 R80 G/S PD 1993 R100GS 2004 K1200GT w/Hannigan S/C 2010 K1300GT
    BMWMOA#52184, AMA#271542, IBA#138

Similar Threads

  1. ABS flashing lights.
    By 155574 in forum Oilheads
    Replies: 2
    Last Post: 06-12-2013, 10:41 PM
  2. ABS lights flashing...still
    By jshuck in forum Oilheads
    Replies: 15
    Last Post: 08-09-2008, 01:30 PM
  3. Flashing ABS lights again
    By Marvhil in forum Flying Brick K-bikes
    Replies: 5
    Last Post: 05-05-2007, 04:06 PM
  4. Replies: 9
    Last Post: 04-07-2007, 07:06 AM
  5. Replies: 11
    Last Post: 08-03-2006, 06:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •