Results 1 to 5 of 5

Thread: New brake pads now vibration

  1. #1
    Registered User
    Join Date
    Dec 2007
    Location
    Midwest
    Posts
    2,145

    New brake pads now vibration

    Only 8,800 miles on this '08 RT, but bought in January and still going through it. While it didn't need pads, I decided to replace anyway....wanted bike in a new state at beginning of ownership. Went with EBC "HH"...easy off with old, on with new. Small amount anti-seize on back plate. Rode this morning getting some slight to moderate shutter/vibes when slowing down. Looked at old pads and noticed while one end of pad material was not tapered the other was. I haven't looked at the new installed pads (just threw them on)...did I miss checking for tapered end (if there is one) to go on at front of disc rotation...or ????

    WHEN WILL A LEARN TO LEAVE WELL ENOUGH ALONE?!
    2008 RT
    MOA #46783

  2. #2
    Most pads have no taper in the direction of travel (the narrow sides). I don't think that is your problem and doubt the EBC pads are tapered there. Most likely you got some contamination on the rotors or pads during installation or didn't break them in properly after installation.

    Here is a decent tutorial...

    https://www.revzilla.com/common-trea...ge-your-brakes

    Don't let a mistake doing something dissuade you from learning and moving on. No-one is born knowing this stuff. Over time you will advance to new and more interesting mistakes. I have found that the permanence of the education rises with the value of the parts ruined.
    Lee A. Dickinson - Danielsville, GA USA
    Airheads #3480 | Iron Butt Assn. #8914
    1976 R75/6 - 1992 R100RS - 1993 K1100RS - 2013 R1200GS

  3. #3
    Registered User
    Join Date
    Dec 2007
    Location
    Midwest
    Posts
    2,145
    Quote Originally Posted by beemerphile View Post
    Most pads have no taper in the direction of travel (the narrow sides). I don't think that is your problem and doubt the EBC pads are tapered there. Most likely you got some contamination on the rotors or pads during installation or didn't break them in properly after installation.

    Here is a decent tutorial...

    https://www.revzilla.com/common-trea...ge-your-brakes

    Don't let a mistake doing something dissuade you from learning and moving on. No-one is born knowing this stuff. Over time you will advance to new and more interesting mistakes. I have found that the permanence of the education rises with the value of the parts ruined.
    Only 15 lightly used miles on them thus far, so not sure break in process is a concern at this stage. And I did clean rotors during pad install. I called EBC for their insight, they said to put 50 to 75 miles on them to see if they smooth out...if not I'm to call them back. Will see what transpires. Never had a problem with new pads before.
    2008 RT
    MOA #46783

  4. #4
    Registered User ExGMan's Avatar
    Join Date
    Sep 2009
    Location
    Chestnut Hill, MA
    Posts
    1,425
    Motodan - I saw your post and even though I have a 2015 RT, I thought I'd reply. I changed all the pads on my 2015 RT yesterday at 29,320 miles, using EBC products. I followed the JVB video to the letter. I did not put anti-seize on the back of the six plates, but did put a very thin layer on the pins (two in front, one in back) that seem to hold everything in the calipers. I took the bike out for a 10-mile ride this afternoon, and all seemed fine. I noticed no immediate difference between the feel and response of the new pads versus the old.

    I've read various bits of information about what is called the "bedding" of the pads. It seems this is the process of getting new pads to adhere (if that's the term) closely to old rotors. EBC offers some information on this process (which lasts about 300 miles) here: https://ebcbrakes.com/articles/motorcycle-bed-in/

    I hope this is helpful.

    JG
    John Gamel
    2015 Ebony Metallic R1200RT
    BMW CCA 2006 - Present; BMW MOA 2009-Present
    Walt Kelly: "We have met the enemy, and he is us."

  5. #5
    Registered User
    Join Date
    Dec 2007
    Location
    Midwest
    Posts
    2,145
    Appreciate the replies. After putting an additional 200 miles on those EBC pads I still wasn't satisfied...they will not stop without vibs from moderate shuddering. I ended up buying (the made of gold - $$$$) BMW pads. As you know they're expensive, but in this case, it was certainly worth it. Brakes are like they should be now, no more shuddering. EBC told me to call them back on this, which I will do. This was an unusual experience with their product. Used them before without problem...I think at least one of the sets is defective.
    Last edited by Motodan; 06-17-2018 at 01:15 PM.
    2008 RT
    MOA #46783

Similar Threads

  1. 1987 R80RT Brake vibration
    By jgp1854 in forum Airheads
    Replies: 6
    Last Post: 11-21-2015, 09:24 PM
  2. 2005 R1200RT Front Brake Vibration
    By RoudyBob in forum Hexheads/Camheads
    Replies: 1
    Last Post: 05-08-2013, 12:26 AM
  3. Front brake pads dragging afternew pads were installed
    By rideaway in forum Hexheads/Camheads
    Replies: 3
    Last Post: 04-24-2013, 02:41 PM
  4. Replies: 4
    Last Post: 10-14-2009, 10:39 PM
  5. OEM brake pads
    By SHOOTER55520 in forum Flying Brick K-bikes
    Replies: 2
    Last Post: 05-09-2009, 11:44 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •