Results 1 to 8 of 8

Thread: 2007 k1200 GT stalled requesting feedback on what may have caused it

  1. #1
    Registered User
    Join Date
    Jan 2009
    Location
    Goshen,CT
    Posts
    55

    2007 k1200 GT stalled requesting feedback on what may have caused it

    2007 K1200GT coming home from work this morning, first 30 miles were on the highway.
    Getting off a long exit ramp I noticed the bike began to backfire numerous times.
    Once I came to a stop the bike stalled, turned it over a few times , ran rough for approximately 5-10 sec then seemed to run normally.
    Any recommendations on what would cause this, and / or items to check or test will be greatly appreciated

  2. #2
    Left Coast Rider
    Join Date
    Nov 2011
    Location
    Vancouver, British Columbia, Canada
    Posts
    2,806
    Bad gas? Clogged fuel filter? Gas cap not venting properly?

    Bike in need of an Italian tune-up? (Run it up to redline full throttle in all gears)
    Last edited by BC1100S; 06-10-2018 at 10:57 PM. Reason: typo

  3. #3
    Registered User
    Join Date
    Jan 2009
    Location
    Goshen,CT
    Posts
    55
    Drained the fuel , will install new fuel filter give it go.

  4. #4
    MOA #24991 Pauls1150's Avatar
    Join Date
    Apr 2008
    Location
    south of Los Angeles
    Posts
    2,440
    From the symptoms described, it sounds electrical to me - intermittent connection, dying coil or ignition sensor (does this version have two coils that fire two plugs? Some use sticks). If it happens again, try to catch what the instruments do at that moment, that'll be a clue.
    Gas or lack thereof should be repeatable over time (but never when the doctor is watching).

  5. #5
    Registered User
    Join Date
    Nov 2004
    Location
    Arizona, USA
    Posts
    75
    jken1986,

    I have a 2008 K1200GT with 126,500 miles on it. I also know three other folks who have or who have owned a GT or an S.

    My GT will occasionally sputtered and die coming to a stop or when slowing way down, like in a dirt construction zone.

    Another GT owner would have erratic running until the bike was turned off and back on. Rebooting the computer so to speak.

    All the K1200GT/S owners I know said that their bike would immediately fire back up, or if the ignition switch was toggled off and on, would run normally again.

    Talking to Mr. Tom Cutter about the problem with the early slant K bikes, he believes it is a firmware/software problem.

    Some bikes have been "cured" by being re-flashed by a dealer. Some not.

    How many miles do you have? When was the last service? Do you do your own services? How many times has this happened?

    How do your ride it? WOT or pretty much under 6 grand.

    Give us some more info so we can see what your bike's pattern is.

  6. #6
    Registered User
    Join Date
    Jan 2009
    Location
    Goshen,CT
    Posts
    55
    i have owned this particular GT just under a year. Bike just turned 10 k miles, 4500 I have put on in the last 10 months. Pretty much ride everyday except wintergreen New England. Do not ride hard.
    Do all my own maintenance.
    After replacing the fuel it appears to be a single episode.

  7. #7
    Left Coast Rider
    Join Date
    Nov 2011
    Location
    Vancouver, British Columbia, Canada
    Posts
    2,806
    Quote Originally Posted by jken1986 View Post
    i have owned this particular GT just under a year. Bike just turned 10 k miles, 4500 I have put on in the last 10 months. Pretty much ride everyday except wintergreen New England. Do not ride hard.
    Do all my own maintenance.
    After replacing the fuel it appears to be a single episode.
    Glad you seem to be all fixed up....but you still need to do an Italian tune up to be sure everything is up to snuff.

  8. #8
    Debbie's Servant Lee's Avatar
    Join Date
    May 2003
    Location
    SW Iowa
    Posts
    5,012
    Quote Originally Posted by jken1986 View Post
    After replacing the fuel it appears to be a single episode.
    Thanks for the update.
    Lee
    2016 R1200RS
    MOA # 30878
    Past BMW Bikes: 2011 K1300S, 2003 K1200RS, 1991 K75S, 1987 K75T, 1984 R100RT

Similar Threads

  1. 2007 1200 RT vs 2007 K1200 GT
    By dhescheles in forum Hexheads/Camheads
    Replies: 7
    Last Post: 07-10-2009, 02:55 AM
  2. K1200 Feedback on alternative exhaust
    By jdaaron in forum Flying Brick K-bikes
    Replies: 4
    Last Post: 04-15-2008, 02:06 AM
  3. 2007 k1200 gt maintenance
    By rmullisjr in forum Flying Brick K-bikes
    Replies: 2
    Last Post: 07-28-2007, 12:46 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •