Results 1 to 3 of 3

Thread: '99 K1200LT Cruise Control after Clutch Replacement

  1. #1
    Registered User
    Join Date
    Aug 2006
    Location
    Southeast Iowa
    Posts
    38

    '99 K1200LT Cruise Control after Clutch Replacement

    I recently did a clutch replacement on a 1999 K1200LT. It shifts smoothly and pulls strong. My problems though are electrical.
    1) The cruise control won't engage. The cable from the control unit to the throttle body wheel is secure and doesn't seem to be bound up. The cruise control indicator light comes on when you slide the switch over, but cruise control doesn't engage when you press the other lever. This is at any speed. The fuse is good and is getting power. The brake lever and pedal switches work.
    How would I test the clutch lever switch?
    2) There is a drain on the battery. It's a 2 year old PC680 which held up well before I did the clutch job.

    I labelled the wires during the tear down process to make sure they went back to the correct connections.

    Any suggestions?

    Thanks, Ted

  2. #2
    Registered User AntonLargiader's Avatar
    Join Date
    Jul 2004
    Location
    Charlottesville, VA
    Posts
    2,019
    You have probably fouled one of the cables on the left side of the engine. This is easy to do when replacing the bodywork; we were told to always check for this when reassembling an LT.

    No good idea on the battery issue, as long as you actually have all of the cables connected. It's easy to miss one of the cables that attach to the front battery terminal.
    Anton Largiader 72724
    Tech articles - YouTube
    Virginia Motorrad Werkstatt BMW motorcycle service and repair in central Virginia

  3. #3
    No idea if this is a likely cause in your case, but I'll throw out the issue I ran into with that era's cruise.
    If there is not enough slack in the throttle cables, the cruise can fail to engage. My guess is that the cruise controller reads this (vibrations?) as attempted throttle movement which by design overrides the CC.
    Same symptoms as yours, and when I slackened the throttle cable , the cruise returned to engaging.

Similar Threads

  1. 2011 R1200RT - Cruise Control On/Off Switch Replacement
    By bdepa in forum Hexheads/Camheads
    Replies: 3
    Last Post: 08-30-2017, 02:55 PM
  2. 99 K1200lt Cruise control problem resolved
    By jcraigcohen in forum Flying Brick K-bikes
    Replies: 2
    Last Post: 07-24-2012, 01:44 AM
  3. cruise control problem 99 K1200LT
    By jcraigcohen in forum Flying Brick K-bikes
    Replies: 6
    Last Post: 06-15-2012, 11:57 PM
  4. K1200LT cruise control not holding????
    By Brycesdad in forum Flying Brick K-bikes
    Replies: 1
    Last Post: 05-06-2009, 02:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •