Results 1 to 2 of 2

Thread: Oil/water Pump Seals (argh!)

  1. #1
    Loading the Bike K75T's Avatar
    Join Date
    Aug 2003
    Location
    Chevy Chase, MD
    Posts
    7

    Oil/water Pump Seals (argh!)

    Well, I think I destroyed my K75's oil/water pump trying to replace the seals.

    Everything went ok until it was time to remove the old seals. When I looked into the pump from the impeller end, I saw a large round thing with a rubbery material around its circumference. I assumed this was the water seal. Yanked off most of the rubber before I realized that this seems to be part of the pump itself. Managed to distort the edges of the metal circle underneath the rubber too, which I assume is going to spell the end of the pump unit.

    Couldn't get all of the old oil seal out of there either, despite lots of fiddling with a screwdriver. For the life of me I can't figure out how the newer hard plastic style oil seal will fit through this little hole underneath the water seal area.

  2. #2
    Loading the Bike K75T's Avatar
    Join Date
    Aug 2003
    Location
    Chevy Chase, MD
    Posts
    7
    Well, I wrote that in a fit of frustration so I'm sure it's completely incomprehensible.

    After studying the diagrams and photos for weeks before doing this job, the interior of the pump looked nothing like I expected when I took off the impeller. Sigh. I guess I'll be buying an all new pump, and maybe a trashy used one to play around with so I can understand the anatomy of this thing.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •