Results 1 to 6 of 6

Thread: Gremlins in my dash

  1. #1
    Registered User
    Join Date
    Apr 2018
    Location
    Lower Lake CA
    Posts
    3

    Gremlins in my dash

    This last weekend several interesting issues popped up on my 14 RT.

    1) The starter switch sometimes needs to be pushed 3/4+ times for the starter to engage, thinking the starter switch is bad?

    2) My programmed display: temp, mileage etc frequently defaults back to a mileage reading after a key cycle from my choice of temp. The center display defaults from speedometer to "RT"

    3) My windshield no longer reacts to the key being turned on or off. The manual button still operates the windshield.

    Gonna try to get it into the shop in the next week, but I thought maybe someone has an idea for me to check prior, or possibly a reset method to bring it all back!

  2. #2
    Liaison 20774's Avatar
    Join Date
    Sep 2005
    Location
    San Antonio, TX
    Posts
    20,711
    Welcome to the forum! Since you have a specific bike question, members with that bike might be able to help. After a bit, one of the moderators will move your question to the Wethead forum area for better eyes on your question.
    Kurt -- Forum Liaison ---> Resources and Links Thread <---
    '78 R100/7 & '69 R69S & '52 R25/2
    mine-ineye-deatheah-pielayah-jooa-kalayus. oolah-minane-hay-meeriah-kal-oyus-algay-a-thaykin', buddy!

  3. #3
    Registered User
    Join Date
    Apr 2018
    Location
    Lower Lake CA
    Posts
    3
    Quote Originally Posted by 20774 View Post
    Welcome to the forum! Since you have a specific bike question, members with that bike might be able to help. After a bit, one of the moderators will move your question to the Wethead forum area for better eyes on your question.
    OK, thanks. As this wasn't a motor issue I wasn't sure which forum area would be best.

  4. #4
    Those seemingly unrelated electrical issues indicate to me it is probably an issue of a bad ground.
    Paul Glaves - "Big Bend", Texas U.S.A
    "The greatest challenge to any thinker is stating the problem in a way that will allow a solution." - Bertrand Russell
    http://web.bigbend.net/~glaves/

  5. #5
    Had almost identical issues with 06 K1200LT last month. Replaced the battery and all was good.

  6. #6
    Registered User
    Join Date
    Apr 2018
    Location
    Lower Lake CA
    Posts
    3
    Quote Originally Posted by mmanleyx6 View Post
    Had almost identical issues with 06 K1200LT last month. Replaced the battery and all was good.
    Interesting, I was wondering if a weak battery could cause these issues. I think the battery's original, so worth a shot before it goes to the shop, thanks.

Similar Threads

  1. Electrical Gremlins . . . .
    By CTellman in forum Airheads
    Replies: 2
    Last Post: 03-18-2013, 11:00 PM
  2. ABS gremlins?
    By BMUUsed in forum Oilheads
    Replies: 9
    Last Post: 10-23-2012, 09:57 PM
  3. Electrical gremlins
    By OfficerImpersonator in forum Oilheads
    Replies: 6
    Last Post: 01-29-2009, 05:19 AM
  4. gremlins in a /5
    By chwood4 in forum Airheads
    Replies: 2
    Last Post: 08-15-2007, 01:25 PM
  5. ABS Gremlins?
    By 120116 in forum Oilheads
    Replies: 5
    Last Post: 08-08-2007, 02:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •