Results 1 to 3 of 3

Thread: 2007 G650- Display Resets

  1. #1
    Registered User powwow's Avatar
    Join Date
    Aug 2015
    Location
    Bend, OR
    Posts
    433

    2007 G650- Display Resets

    I've been casually shopping for a G650 and recently noticed one in CL. It's a 2007 G650 XCountry with 25K miles. The owner says it runs great with the following exception (in his words):

    "The only issue I am having now is at low RPM the display resets. New battery, zero mechanical issues aside from electrical problem at the moment. The battery charges fine but it could be that the stator is on its way out and is not providing enough juice at low RPM."

    Would some of you who are familiar with this bike agree with his diagnosis? If so, how big of a job is it to replace the stator?

    Thanks for any direction you could provide.

  2. #2
    You can call up a voltmeter on the XCountry display and see what happens to the output at low rpm's. If there is a problem, look at the voltage regulator before replacing the alternator.

    A bad battery can also cause all sorts of issues with these bikes.

    These displays are sensitive to voltage spikes, like when an HID auxiliary lamp ignites. Your problem may be something like that or a bad display or a faulty ground.

    This could be many things.

    Post your question here-

    http://advrider.com/index.php?thread...90240/page-581


    .

  3. #3
    Registered User powwow's Avatar
    Join Date
    Aug 2015
    Location
    Bend, OR
    Posts
    433
    Quote Originally Posted by leafman60 View Post
    You can call up a voltmeter on the XCountry display and see what happens to the output at low rpm's. If there is a problem, look at the voltage regulator before replacing the alternator.

    A bad battery can also cause all sorts of issues with these bikes.

    These displays are sensitive to voltage spikes, like when an HID auxiliary lamp ignites. Your problem may be something like that or a bad display or a faulty ground.

    This could be many things.

    Post your question here-

    http://advrider.com/index.php?thread...90240/page-581


    .
    Thanks!

Similar Threads

  1. Clock resets to 0:00 when starting
    By DaveSlash5 in forum Oilheads
    Replies: 18
    Last Post: 10-13-2017, 06:00 PM
  2. 2007 R 12 R display blank
    By henzilla in forum Hexheads/Camheads
    Replies: 6
    Last Post: 11-22-2016, 03:04 AM
  3. Tripmeter 2 resets on its own 2011 R1200RT
    By kltk165 in forum Hexheads/Camheads
    Replies: 16
    Last Post: 11-09-2011, 11:45 PM
  4. Dash Clock Resets Itself
    By E_Page in forum Oilheads
    Replies: 11
    Last Post: 01-13-2010, 11:51 PM
  5. Tachometer for 2007 BMW G650 XCountry
    By will.kraham in forum Thumpers - F & G bikes
    Replies: 2
    Last Post: 10-12-2007, 11:34 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •