Page 1 of 2 1 2 LastLast
Results 1 to 15 of 16

Thread: '17 RT...GPS Does Not Turn On....

  1. #1

    '17 RT...GPS Does Not Turn On....

    I have a '17 RT with GPS prep pack. Bought a Nav V, charged battery, installed in OEM cradle, turned bike on and GPS does not automatically come on as stated it should in Garmin manual. I had same set up on '15 GS and worked fine, including all specific bike related details...no luck either with specific bike related details on this new unit on bike. When I manually turn on the unit, works fine, except the bike specific details. I am the first to admit I can really be a tech idiot but this really doesn't make sense. To me, it is if the GPS electrical pins on the back are not connecting with the mount pins. Oh yes, the Info button never does show the GPS screen when switching through various options on the Info switch gear. Yes, the GPS is fully snapped in place on the mount. HELP! Many thanks in advance!

  2. #2
    Registered User
    Join Date
    Aug 2009
    Location
    Lexington, SC
    Posts
    47

    Nav V doesn't synch to '17

    Any chance the dealer has to "enable" that functionality with the GPS prep? I know a lot of systems need to be enabled but not familiar if this is the case with your '17 - seems odd it worked as it should on prior bikes but not when docked to your '17 unless there's a Bavarian Elf stuck somewhere in the GPS wiring harness........

  3. #3
    Addicted to curves azgman's Avatar
    Join Date
    Jun 2003
    Location
    AZ
    Posts
    834
    It is either not enabled or the wiring is disconnected. Take a trip to the dealer.
    MOA #107139
    RA #28511

  4. #4
    Good advice on the enabling! Will contact the dealer. Many thanks!

  5. #5
    Ed Kilner #176066
    Join Date
    Nov 2011
    Location
    Mississauga, ON
    Posts
    1,047
    Quote Originally Posted by shropdog View Post
    I have a '17 RT with GPS prep pack. Bought a Nav V, charged battery, installed in OEM cradle, turned bike on and GPS does not automatically come on as stated it should in Garmin manual. I had same set up on '15 GS and worked fine, including all specific bike related details...no luck either with specific bike related details on this new unit on bike. When I manually turn on the unit, works fine, except the bike specific details. I am the first to admit I can really be a tech idiot but this really doesn't make sense. To me, it is if the GPS electrical pins on the back are not connecting with the mount pins. Oh yes, the Info button never does show the GPS screen when switching through various options on the Info switch gear. Yes, the GPS is fully snapped in place on the mount. HELP! Many thanks in advance!
    yes, see the dealer. And, you will not get all the info the GS provides. BMW has chosen not to provide that facility. Very limited wonder wheel operations. Rather disappointing.
    Ed
    2015 R1200RT; 2011 R1200RT RIP; 2000 Triumph 900 (sold)
    http://triumphantsblog.blogspot.ca/

  6. #6
    Registered User marcopolo's Avatar
    Join Date
    Feb 2005
    Location
    Alexandria Virginia/Ottawa, Canada
    Posts
    897
    When I picked up my new 2015 GSA, the dealership had not plugged in the connector for the GPS prep mount (part of pre-delivery inspection).
    Mark
    2015 R 1200 GS Adventure

  7. #7
    Quote Originally Posted by marcopolo View Post
    When I picked up my new 2015 GSA, the dealership had not plugged in the connector for the GPS prep mount (part of pre-delivery inspection).
    Any idea where the GPS connector plug is located? I called two dealers, both said the bike does not need to be enabled to run the GPS!?!? Both suggested I take an alcohol cleaning pad and clean the pins on the cradle and GPS, which I am going to do this evening. If not that, then the cradle appears to be the issue (both dealers reported they have had cradle failures). My closest dealer is 1.5 hours away and I would have to make a trip to have it diagnosed, they would order a cradle and make a second visit to have installed. So....I think I am going to call the dealer in Salt Lake and see if I can beg them to have a cradle in stock and then make an appointment when in SLC for the rally.

  8. #8
    Registered User
    Join Date
    Mar 2010
    Location
    Wills Point, TX
    Posts
    306
    Quote Originally Posted by shropdog View Post
    Any idea where the GPS connector plug is located? I called two dealers, both said the bike does not need to be enabled to run the GPS!?!? Both suggested I take an alcohol cleaning pad and clean the pins on the cradle and GPS, which I am going to do this evening. If not that, then the cradle appears to be the issue (both dealers reported they have had cradle failures). My closest dealer is 1.5 hours away and I would have to make a trip to have it diagnosed, they would order a cradle and make a second visit to have installed. So....I think I am going to call the dealer in Salt Lake and see if I can beg them to have a cradle in stock and then make an appointment when in SLC for the rally.
    The following is a link from Real OEM showing the parts http://www.realoem.com/bmw/enUS/show...diagId=77_0656 the lead doesn't look long, you should be able to find the connection without that much work.

    Jay

  9. #9
    Registered User AKsuited's Avatar
    Join Date
    Jul 2009
    Location
    Southern Tier of New York
    Posts
    1,580
    How long did you give it to come on?

    Even with a partial charge, the Nav V on my wethead GS sometimes takes 5 minutes or so to light up.

    Harry
    My fleet: 2015 R1200GS, 2017 Toyota Prius Prime (plug-in hybrid)

  10. #10
    Addicted to curves azgman's Avatar
    Join Date
    Jun 2003
    Location
    AZ
    Posts
    834
    Quote Originally Posted by AKsuited View Post
    How long did you give it to come on?

    Even with a partial charge, the Nav V on my wethead GS sometimes takes 5 minutes or so to light up.

    Harry
    That is not normal. My Nav V starts up almost immediately upon powering on the bike.

    As far as the GPS connector goes, just follow the wire from the cradle back until you get to a connector!
    MOA #107139
    RA #28511

  11. #11
    Registered User wbrownell9's Avatar
    Join Date
    Jun 2013
    Location
    New Castle, DE
    Posts
    270
    Quote Originally Posted by BMW Triumphant View Post
    yes, see the dealer. And, you will not get all the info the GS provides. BMW has chosen not to provide that facility. Very limited wonder wheel operations. Rather disappointing.
    What information or functionality do you think is missing? I think lean angle got removed in a firmware update some time back, possibly because "some" people were getting in over their heads trying for max lean. I'm satisfied with what the GS wonder wheel does. I do have to physically touch the unit to select a route, and look for POIs, but I should be stopped for that anyway. Emphasis on "should" The only thing I'd like the wonderwheel to do is get upcoming turn-by-turn directions which I don't need to do often.

    Quote Originally Posted by AKsuited View Post
    How long did you give it to come on?

    Even with a partial charge, the Nav V on my wethead GS sometimes takes 5 minutes or so to light up.

    Harry
    My unit has taken to coming on bright, then going very dim, then coming up to whatever it decides Auto Brightness should be. It used to come up at the "right" brightness as soon as I turned the key.
    2016 R1200 GSA

  12. #12
    Ed Kilner #176066
    Join Date
    Nov 2011
    Location
    Mississauga, ON
    Posts
    1,047
    Quote Originally Posted by wbrownell9 View Post
    What information or functionality do you think is missing? I think lean angle got removed in a firmware update some time back, possibly because "some" people were getting in over their heads trying for max lean. I'm satisfied with what the GS wonder wheel does. I do have to physically touch the unit to select a route, and look for POIs, but I should be stopped for that anyway. Emphasis on "should" The only thing I'd like the wonderwheel to do is get upcoming turn-by-turn directions which I don't need to do often.


    .
    Forgot the name of the application that gives a nice page full of GS info like brake applications and much more. That app is missing entirely from the RT implementation. I believe there are things you can do on that page or elsewhere on a GS using the wonder wheel that are simply missing on the RT implementation. Don't have a reference doc to share, but there have been posts about this.
    Ed
    2015 R1200RT; 2011 R1200RT RIP; 2000 Triumph 900 (sold)
    http://triumphantsblog.blogspot.ca/

  13. #13
    FUKENGRUVEN SURVIVOR akbeemer's Avatar
    Join Date
    Jul 2007
    Location
    THE BIG SKY
    Posts
    6,397
    Will other Garmins work in the cradle on 2017 R bikes?
    Kevin Huddy
    Tm Pterodactyl MT Outpost

  14. #14
    Debbie's Servant Lee's Avatar
    Join Date
    May 2003
    Location
    SW Iowa
    Posts
    4,121
    Quote Originally Posted by AKsuited View Post
    How long did you give it to come on?

    Even with a partial charge, the Nav V on my wethead GS sometimes takes 5 minutes or so to light up.

    Harry
    Something is wrong with your GPS or cradle.
    Both of our Nav V units power up within seconds of turning on our wethead bikes.
    Lee
    2016 R1200RS
    MOA # 30878
    Past BMW Bikes: 2011 K1300S, 2003 K1200RS, 1991 K75S, 1987 K75T, 1984 R100RT

  15. #15
    Addicted to curves azgman's Avatar
    Join Date
    Jun 2003
    Location
    AZ
    Posts
    834
    Quote Originally Posted by akbeemer View Post
    Will other Garmins work in the cradle on 2017 R bikes?
    Yes, the Zumo 660 and Zumo 665 will for sure, but you will not get wonderwheel integration or the additional BMW screens (like my motorcycle). I had a Zumo 665 on my 2017 GS before I bought a used Nav V.
    MOA #107139
    RA #28511

Similar Threads

  1. Turn signal won't turn off K75RT-P 1991
    By WalterK75 in forum Flying Brick K-bikes
    Replies: 4
    Last Post: 08-14-2013, 10:53 PM
  2. ASC: When to turn off?
    By Eldor in forum Motorrad
    Replies: 3
    Last Post: 09-21-2012, 04:53 PM
  3. Turn you on...
    By redclfco in forum Campfire
    Replies: 16
    Last Post: 06-15-2009, 06:39 PM
  4. Is there a way to turn off.....
    By xp8103 in forum Online Central
    Replies: 1
    Last Post: 05-01-2008, 05:15 AM
  5. /5 won't turn over
    By LCampbell in forum Airheads
    Replies: 14
    Last Post: 03-05-2007, 03:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •