Results 1 to 9 of 9

Thread: EZCAN Issue

  1. #1
    Plockster
    Join Date
    Mar 2006
    Location
    East Granby, CT
    Posts
    56

    EZCAN Issue

    Hi all,

    I have had an Ezcan installed on my 2016GS for about two months now, and as of a few days ago, it was working great. However, suddenly my auxiliary lights have stopped working. After re-examining connections and trying to reset the software, this is what I have found:

    If I use the setup software and plug the USB cable to the device, the lights work again. However, as soon as I unplug the USB, the lights go off. I also notice that the little green light on the device goes out. Should that light be on even when not connected to the software?

    It seems like the device is not holding the configuration information when not connected to the PC and configuration software. I'm thinking that perhaps it's only getting power from the USB connection and not the battery, but all other electrical functions on the bike work fine. Has anyone run into this before? Am I missing something simple?

    Thanks,
    Dan
    1994 K75 (sold)
    2004 R1150RT (sold)
    2016 R1200GS

  2. #2
    Ed Kilner #176066
    Join Date
    Nov 2011
    Location
    Mississauga, ON
    Posts
    1,047
    New and rare item, so few of us will have experience.

    Might be infant mortality, might be what you have connected, might be software.

    Should be under warranty.

    Do let us know the outcome!
    Ed
    2015 R1200RT; 2011 R1200RT RIP; 2000 Triumph 900 (sold)
    http://triumphantsblog.blogspot.ca/

  3. #3
    #13338 PGlaves's Avatar
    Join Date
    Oct 2003
    Location
    "Big Bend" TX
    Posts
    21,696
    Ain't technology wonderful? I have reached the point where these kinds of glitches drive me nuts. When Voni catches me grumbling colorful words expanding her vocabulary she knows I just discovered another technology failure.
    Paul Glaves - "Big Bend", Texas U.S.A
    "The greatest challenge to any thinker is stating the problem in a way that will allow a solution." - Bertrand Russell
    http://web.bigbend.net/~glaves/

  4. #4
    Barback King rapiddog's Avatar
    Join Date
    Jan 2004
    Location
    Acton, SoCal just West of Hell
    Posts
    468

    MeToo

    ...searched for 'EZcan' so this came up...

    My EZcan with Denali D2's installed per instructions to a T worked fine for about2 months.
    Then they started going out or working intermittently.
    I tried everything. Re-wiring, updating firmeware and re programming, et al.
    Hex responded and walked me through suggestions.
    Unplug it and re-plug it.
    Check disganostics.
    Check fuse.

    They asked me to send it back to The Beemershop where I bought it....evidently a faulty unit.
    So now I wait.
    Just putting me down for a fail.
    "...the burble of my exhaust unwound like a long cord behind me. Soon my speed snapped it, and I heard only the cry of the wind...." Larry of Arubia

  5. #5
    I have the same problem. It took over a year to surface. Any resolution to this??

  6. #6

    Same problem--resolved

    I had the same problem, namely that everything would work when hooked to computer, but not otherwise. After an email exchange with the factory tech reps I received a no-cost replacement from the distributor that I purchased it from. New one has been working fine since. Whole process took about a week.

  7. #7
    Registered User wbrownell9's Avatar
    Join Date
    Jun 2013
    Location
    New Castle, DE
    Posts
    575
    Similar happened to me, all was fine when I left one day, then the lights went out and wouldn't come on (sometimes I cancel the turn signals wrong and accidentally turn them off). When I got home I found that they came on with the ignition but went out when started. Pulled the seat, the light that's normally green was red. Plugged in the computer, changed fuse value from 1A to 2A per light, everything works fine. I'm not entirely delighted with this solution as PIAA says the lights only draw 1/2 amp each. Also the bike is sleeping until March so I won't know if it's a durable solution for some time.

    It seems that if (a) the unit is hooked into the CANbus properly and (b) the bike is powered on and (c) the computer is connected, the ezCAN will show the green (or in my case, red) light. Doesn't matter if the bike is running or even if the unit is actually getting 12V, just being hooked to the CANbus will allow the status light to come on. I had a dumb attack about powering it - I power it from a Neutrino not a direct battery connection which I hadn't configured it to actually supply power to the ezCAN. Once I fixed that the ezCAN worked fine.
    2020 R1250 GSA Low

  8. #8
    Had the same issue with an ezCan on my 2001 R1200GS. Contacted ezCan and they are sending out a replacement. 2 Year warranty.

  9. #9

    Mine broke as well

    They have had my defective device for 1.5 months. I don't know why I am having to wait so long for a replacement

Similar Threads

  1. Replies: 16
    Last Post: 07-20-2017, 02:00 AM
  2. Satellite Radio Issue/Ipod Issue
    By 57525 in forum Straight 6 K1600 GT/GTL/B
    Replies: 7
    Last Post: 10-01-2012, 11:47 AM
  3. Ews issue
    By Wwilliams819 in forum F-Twins
    Replies: 1
    Last Post: 09-02-2012, 02:08 AM
  4. R 80 GS Issue
    By dougjordan in forum Airheads
    Replies: 1
    Last Post: 08-08-2012, 03:59 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •