Results 1 to 4 of 4

Thread: R50/2 front end wobble

  1. #1
    Registered User ripperfarms's Avatar
    Join Date
    Jul 2006
    Location
    Central IL
    Posts
    87

    R50/2 front end wobble

    I have a 66 R50/2 with Jawa/Velorex sidecar.

    It wobbles at low speed. It does come out of it when going a little faster.

    Dave in central il.

    Thanks for any help.
    1966 R50/2 with Jawa/Velorex sidecar

  2. #2
    Airmarshal-IL James.A's Avatar
    Join Date
    Sep 2013
    Location
    central Illinois
    Posts
    469
    Dave, My /7 with Velorex does that too. I have seen some rigs where the owner installed a steering damper from a type 3 volkswagen (fastback,squareback) between the sidecar frame and the right side fork. If your /2 has it's friction type steering damper in place, you might try fiddling with that. Also, make sure the steering head bearings are adjusted just right.
    1973 R75/5

  3. #3
    Donmystic1
    Join Date
    Jul 2009
    Location
    Mystic, CT
    Posts
    187
    My R50/2 with a Steib S500 had the same issue. Tightening the steering damner clockwise solved the problem

    Don

    IMG_20150505_120729269.jpg

    IMG_20150123_113500772.jpg

  4. #4
    Registered User ripperfarms's Avatar
    Join Date
    Jul 2006
    Location
    Central IL
    Posts
    87

    R50 with sidecar

    Quote Originally Posted by donmystic1 View Post
    My R50/2 with a Steib S500 had the same issue. Tightening the steering damner clockwise solved the problem

    Don

    IMG_20150505_120729269.jpg

    IMG_20150123_113500772.jpg
    Thanks..........I going to try the steering dampner first.............then maybe think about a shock to the front fork later.......

    Thanks everyone for your help.............dave in central IL
    1966 R50/2 with Jawa/Velorex sidecar

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •