Results 1 to 3 of 3

Thread: '92 R100 GS front brake switch stopped working?

  1. #1
    Ran Bush
    Join Date
    Jan 2006
    Location
    Nor Cal
    Posts
    53

    '92 R100 GS front brake switch stopped working?

    '92 R100 GS. I was on a ride the other day, and at a stop the guy behind me told me my brake light wasn't lighting up in any of the turns. Today I take a look and find that the front brake switch seems to have stopped working. Stepping on the rear brake pedal lights the brake light, but pulling on the front brake lever doesn't light the brake light.

    I took the lever apart, cleaned and greased the housing and the pivot bolt, disconnected the cable/switch, squirted some contact cleaner in the switch, pushed the switch in a few times, still didn't light the brake light. Put it back together. No joy.

    The picture of the switch at the Max BMW parts fiche seems to show the switch plunger on a new part may be a little longer than the plunger on my switch. The new cable switch is about $38, but I'd like to fix this one if I could. Do the switches get tired and die after twenty years or so?

    Any input appreciated. Thanks.
    Attached Images Attached Images
    Ran Bush in NorCal

  2. #2
    Registered User
    Join Date
    Apr 2005
    Location
    Western New York State
    Posts
    189
    The rear brake switch went out on my 1990 R100RT. I did what you did and figured it wasn't worth the hassle and just ordered a new one from MAX. I looked the bike over and found some other parts it needed and ordered everything at once.

  3. #3
    Mine went out on my 85 R80 a couple of months ago. I tied cleaning it etc. without good results. For the sake of safety, just get a new switch.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •