Results 1 to 3 of 3

Thread: K100RS oil in coolant tank sight gauge.

  1. #1
    oldpilot
    Join Date
    Jan 2010
    Location
    Richmond, Va.
    Posts
    30

    K100RS oil in coolant tank sight gauge.

    1986 K100RS with 29K miles.
    During this mornings oil / filter change, general look over the bike I noticed something
    that concerns me.
    In the plastic sight tube on the coolant tank I notice a small amount of what looks
    like motoroil on the surface of the coolant. ( about 1/4 -1/2 inch )
    In starts and runs great no smoke etc. The oil I drained for the change was dark but no signs
    of water, filter contents OK also.
    Do I have a problem or not to worry?
    Thanks for any advice, Capt. Bob

  2. #2
    Registered User
    Join Date
    Mar 2008
    Location
    Belton Tx
    Posts
    703
    I had the same thing in the overflow bottle and the radiator. I removed the oil/water pump and had a dealer rebuild it. No more oil in the coolant.

    I would not delay in getting it fixed.
    Ron

    91 K75RT ABS

  3. #3
    oldpilot
    Join Date
    Jan 2010
    Location
    Richmond, Va.
    Posts
    30

    k100RS oil in coolant tank

    As a follow up to my problem, I removed the oil/water pump assy. last nite and the cause of the problem was obvious. The shaft seal was in pieces and the shaft bearing surface
    was badly scored.
    My local dealer suggested that some times the pump weep hole will indicate some fluid
    leakage. My K 100 did not leak any fluid because I found the weep hole was completely
    blocked from an insect. ( probably a mud wasp ).
    I think if the hole had been open I would have noticed oil dripping on my garage floor after
    riding the bike.
    Thanks again for the good advise.
    Bob w

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •