Results 1 to 4 of 4

Thread: Daniel, US Army Retired

  1. #1
    158008
    Guest

    Daniel, US Army Retired

    I have a LT1200, 2003 with 16,000 miles. I had it worked on installing PIAA lights, new battery and rear end oil change. I noticed today that the engine at start up and during idle runs rough, going from 900 rps to 1200 rps. During reverse the idle should rep-up and does not. Can anybody assist me. My repairshop normally does a good job but does not have the el tools to tap into a BMW. Any ideas? Thanks. Daniel

  2. #2
    Supporting our Vets jers99lt's Avatar
    Join Date
    Jun 2010
    Location
    Warrenville, IL
    Posts
    161
    Welcome to the forum. It sounds like the idle and reverse rev started after the PIAA's were installed. Correct? Certainly a place to look for grounding issues.
    Take some time to search the BMWLT.com forum and if nothing turns up, ask them. There is a larger concentration on K1200LT owners there and they're always very willing to help.

    HTH,
    Jer
    Jerry Palma
    99 K1200LTI Champagne 'Oh, Kay' (dropped: 6); 97 K1100LT Aspen Silver Night 'The Silver Knight';
    I love these bikes regardless of what I've needed to fix on them. I'll: Just Ride 'em!

  3. #3
    You stupid, fix it! r11rs94's Avatar
    Join Date
    Jan 2006
    Location
    Tiverton, RI
    Posts
    5,153
    Quote Originally Posted by 158008 View Post
    I have a LT1200, 2003 with 16,000 miles. I had it worked on installing PIAA lights, new battery and rear end oil change. I noticed today that the engine at start up and during idle runs rough, going from 900 rps to 1200 rps. During reverse the idle should rep-up and does not. Can anybody assist me. My repairshop normally does a good job but does not have the el tools to tap into a BMW. Any ideas? Thanks. Daniel
    Hi Daniel, I cannot help with the LT proplem so I'll just say welcome aboard...
    The thing about traveling is, you never want it to end and you can't wait to get home.
    I answer to Roy, Chief, or Sarg.
    04 R-1150-RT current bike. 94 R-1100-RS74,383, Sold, 78 R-80/7, K.I.A by a D.U.I
    www.OceanStateBMWriders.com

  4. #4
    Polarbear Polarbear's Avatar
    Join Date
    Jan 2006
    Location
    Clovis,CA
    Posts
    4,220

    Had one too:)

    Great bike, mine was 2001 and I rode her 98000miles and sold it to my brother who still rides it at 110000m now. Battery change? Be sure its already up to fully charged. A 100% battery is important! Use some Techron(Chevron product) in the gas tank for one tank, works great on the whole gas system. I did all my own service and found it a days job to do a complete service, fairing off. Found a rider from Louisiana last year on my tour of the NW at Mt.St.Helens on a 2001 KLT1200, just turning 200000miles on it. I smiled. Welcome. Randy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •