Results 1 to 5 of 5

Thread: Question about '03 F650CS

  1. #1
    Rally Rat
    Join Date
    Jan 2007
    Location
    Payson, AZ
    Posts
    764

    Question about '03 F650CS

    After today's ride, while backing the bike into the garage, in neutral, I noticed a clicking sound coming from the rear. Never heard it before. So I moved it forward and heard it again, back, heard it again. It was fine when I went out to ride this am.

    Any ideas on what this would be? Belt, maybe? I checked it and seems tight as can be. Anyway, I'm stumped and could use some suggestions as to what might be causing this clicking noise. Thanks!

  2. #2
    Cage Rattler wezul's Avatar
    Join Date
    Nov 2006
    Location
    Glen Ellyn, IL
    Posts
    3,788
    Check for road debris in caught up in rear wheel maybe? :shrug

  3. #3
    Registered User SilverRT's Avatar
    Join Date
    Feb 2007
    Location
    Lake Elmo, MN
    Posts
    79

    Clicking Sound

    You might want to ask this question on the Chain Gange site. My CS does the same thing and always has. I'm not sure it's a serious issue.
    R1200RT '16, R1200GS '13
    R1200RT '07, R1150RT '04 & K75RT '93 Sold

    "It's all about the journey, make the best of the road you find yourself on."

  4. #4
    Rally Rat
    Join Date
    Jan 2007
    Location
    Payson, AZ
    Posts
    764
    Last time I back it into the garage it didn't make the noise so I'm assuming it was nothing.

    Hey! Am I in the correct thread!!

  5. #5
    Polarbear Polarbear's Avatar
    Join Date
    Jan 2006
    Location
    Clovis,CA
    Posts
    4,220

    Some tips:)

    Be sure your belt pulleys(2) are tight and seated well, belts are not too old and worn and wheel bearing noise, which is real bad! No noise is always best. Randy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •