Results 1 to 3 of 3

Thread: Wonky '03 K1200GT starter button

  1. #1
    67-year-old Teenager indygt's Avatar
    Join Date
    Jun 2003
    Location
    NE Arkansas - Between Goobertown and Buck Snort
    Posts
    397

    Wonky '03 K1200GT starter button

    Has anyone else had problems with the starter button on the '03 K1200GT?
    I often have to push it a second time to get the starter to crank. A third time on rare occasions.
    John M. Flora
    '03 K1200GT, '94 K75S
    MOA # 23538, RA # 16295, AMA Life Member
    Secret Squadron # SQ24418

  2. #2
    Registered User 58058D's Avatar
    Join Date
    Jun 2007
    Location
    Mendocino, CA USA about as far left as you can get in the lower 48
    Posts
    870
    Not a good sign.
    Jim Douglas '00 K1200RS >138,000 miles -- Black, 01/10/2000 to present
    Gone: White '09 K1300S sold @ 22k mi, Black '93 K1100RS traded @ 78k mi, Red '85 K100RS sold @ 44k mi, '06 Kaw 650R chrome yellow track bike sold http://www.seagullbb.com/

  3. #3
    67-year-old Teenager indygt's Avatar
    Join Date
    Jun 2003
    Location
    NE Arkansas - Between Goobertown and Buck Snort
    Posts
    397
    Yeah, especially this close to my departure for Redmond.
    I have an appointment with my dealer next week to get it replaced for about $350.
    John M. Flora
    '03 K1200GT, '94 K75S
    MOA # 23538, RA # 16295, AMA Life Member
    Secret Squadron # SQ24418

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •