Results 1 to 5 of 5

Thread: Is there a "No O2 sensor Cat Code Plug needed for Motronic 2.2?

  1. #1
    94627
    Guest

    Is there a "No O2 sensor Cat Code Plug needed for Motronic 2.2?

    My 1997 11RS has almost 40K...so...with kind assistance........installed potentiometer, new throttle cables, synched TB's carefully, adjusted valves, pulled ccp(yellow), cleared Motronic 2.2(fuse 5), and disconnected O2 sensor...also new Hall Effect sensor and fuel filter........... gas analyzer(CO near 10%) and nose reported a very rich mixture.
    Now running with O2 sensor connected, no ccp, and potentiometer connected. Potentiometer can trim CO to near 4%. Runs better and stronger and cooler when warmed up and under load. The bike idles well when cold, but when it warms up the idle is rough and hunts back and forth about 3-400 rpm(900-1300 range) and the RS still surges under light throttle and vibrates more than original, surging stock set-up.
    Suspect O2 sensor (bad or slow). I would prefer to run in no O2 sensor-open loop operation.

    Is there some "no O2 sensor ccp" required for the motronic to see the potentiometer and stay in open loop? Now the ECU seems to see both the O2 sensor and the potentiometer. Ideas would be appreciated. Thanks....bert

  2. #2
    From what I have read on the net, if your CCP is out, your O2 sensor is not in the loop in the Motronic 2.2 engines.

  3. #3
    94627
    Guest

    Question

    I too understood that without ccp and without the O2 sensor the potentiometer was seen. But I found a reference to a possible "no O2 sensor"ccp. Does the change to idle as the engine warms indicate motronic reverting to closed loop operation as opposed to the open loop, potentiometer controlled mode? If bike was running closed loop would the potentiometer make any difference to CO levels at all? I will try a new O2 sensor just to see if that is creating the slow swing of rpm's at idle when the engine is warm. Any ideas......thanks.

  4. #4
    Back in the Saddle mcmxcivrs's Avatar
    Join Date
    Apr 2003
    Location
    Calgary
    Posts
    2,101
    I don't know of an Non - O2 sensor chip. The early RSs like my 94 did not have the 02 sensor and do not use a chip. My understanding is that the chip is built-in in these early versions. They also did not have the catalytic convertor either. If you do run this modified system, you may want to look at removing your convertor too as it could overheat and lead to a melt down if the mixture remains too rich.

    FWIW, my 94 with nearly 130,000 kms on it still runs flawlessly and has never ever surged. The lack of an O2 sensor might be a big part of that.

    Good luck with your experimenting.
    Ed Miller, Calgary, AB
    2008 K1200GT, 2019 F850GSA

  5. #5
    94627
    Guest
    yes.....Converter seems to have died without becoming obstructed. Evidence is that it is no hotter than the exhaust pipe both upstream and downstream. I am enjoying the cool...so is the transmission which seems to shift easier when bike gets hot in traffic.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •