Results 1 to 4 of 4

Thread: Alpine Audio Unit Repair

  1. #1
    Manic Mechanic Furman's Avatar
    Join Date
    Nov 2005
    Location
    Washington Crossing, Pa. Along the Delaware River
    Posts
    54

    Alpine Audio Unit Repair

    Looking for an electronic repair shop that can repair the Bluetooth issue I am having with my Alpine audio unit.

    The issue I am having is with the Bluetooth connection dropping out. I get audio (radio, navigation and phone) via Bluetooth to my BMW helmet headset. I would get a message on my GPS screen that Bluetooth connection is lost. This seemed to happen more often when I had a passenger with me. The Bluetooth antenna is located under the seat where the passenger sits. It like the passenger is blocking the Bluetooth signal from the antenna. The system has been paired cleared and paired again as per BMW manual many times.

    Items that have been replaced.
    GPS BMW Navigator V Garmin unit
    BMW communicator helmet units. Both driver and passenger.
    Bluetooth antenna located under seat.
    Cell phone.

    One thing that helped was relocating the Bluetooth antenna from under the seat to the space between the seat and fuel tank. It has an open view to the drivers helmet. But if I lean over the antenna I loose the signal again.

    I did send it to United Radio an Alpine repair shop but they could not help. A new replacement unit is over $2000 then the labor at the dealer to program it. There are some units on Ebay but I don't know if everything works intel I get it programmed to the bike.

    Has anyone had luck getting the Alpine module repaired? Thanks

  2. #2
    Issues with BMW's bluetooth in the K1600 and wetheads have been around for awhile. Following is a link with some work arounds -

    https://forums.bmwmoa.org/showthread...ith-Blue-tooth

  3. #3
    Manic Mechanic Furman's Avatar
    Join Date
    Nov 2005
    Location
    Washington Crossing, Pa. Along the Delaware River
    Posts
    54
    Quote Originally Posted by robsryder View Post
    Issues with BMW's bluetooth in the K1600 and wetheads have been around for awhile. Following is a link with some work arounds -

    https://forums.bmwmoa.org/showthread...ith-Blue-tooth
    Thanks for the reply. I did see that. Does Sena still make that SM10 unit? And will it work with the BMW communicators? I was fine with the way it was. Was just tiring to get the Bluetooth repaired in the Alpine unit. I just got the audio unit back from United Radio repair. They said they could not help since that Alpine unit is discontinued. But I did reinstall it and everything is working now. I love the K1600GTL but why did BMW choice such a bad system (maybe they were the cheapest) Thanks Again.

  4. #4
    I didn't care about bluetooth. I went with some wired earphones from the Motochello

    https://www.motochello.com/audio-speaker-bridge/

    I like the S plugs

    https://www.plugup.com/the_S_plug_st...rbuds_s/67.htm

Similar Threads

  1. '04 R1150RT Fuel Sending Unit Repair?
    By txmxrider in forum Oilheads
    Replies: 11
    Last Post: 10-22-2021, 11:07 PM
  2. ABS Control Unit Repair VS. Used 93 K75S
    By DarrenP in forum Flying Brick K-bikes
    Replies: 5
    Last Post: 11-30-2012, 07:45 PM
  3. 2010+ RT Audio Control Unit Pics
    By kltk165 in forum Hexheads/Camheads
    Replies: 0
    Last Post: 12-16-2011, 03:22 AM
  4. Replies: 0
    Last Post: 06-06-2007, 09:33 PM
  5. Helmet Cam on the GS to an Alpine Lake
    By sfarson in forum Ride Reports
    Replies: 7
    Last Post: 08-30-2005, 05:06 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •