Results 1 to 9 of 9

Thread: '03 K1200RS Electrical Gremlin

  1. #1
    Registered User VIEJO's Avatar
    Join Date
    Feb 2013
    Location
    Hutto, Texas
    Posts
    122

    '03 K1200RS Electrical Gremlin

    My '03 K1200RS (42K) has never missed a beat since I bought it new, but, about two weeks ago when I turned on the ignition key the dash lights came on full strength, I heard the ABS pump ramp up, and got no response when I hit the starter button (kill switch in he run position). I recycled the ignition switch and the dash lights only came on at about half power and the ABS pump did not ramp up. I recycled the ignition switch a few more times, everything energized normally, and the bike started and ran with no further issues. Several more normal starts over the next few days but yesterday it reverted back to dim dash lights, no ABS pump ramp up, no starter engagement. The battery is good (on a minder), battery connections are clean and tight at the posts, and there is no visible sign of arcing or shorting in the electrical relay box.

    I suspect either a faulty ignition switch or faulty kill switch but my electrical diagnostic abilities are limited at best and it is very easy to make a very expensive mistake here.

    Are these symptoms familiar to anyone?

    Thanks,

    Dave

  2. #2
    Fortis Fortuna Adiuvat Omega Man's Avatar
    Join Date
    Jan 2010
    Location
    Mansfield,MA
    Posts
    17,323
    My first question is battery age.
    OM
    "You can do good or you can do well. Sooner or later they make you choose." MI5
    Mod Squad
    2009 F800GS 1994 TW200

  3. #3
    Registered User VIEJO's Avatar
    Join Date
    Feb 2013
    Location
    Hutto, Texas
    Posts
    122
    Quote Originally Posted by Omega Man View Post
    My first question is battery age.
    OM
    AGM/14 months..... when cycling the ignition switch on previous non-starts the dash lights/ABS pump would power up normally and then on the next cycle the dash lights came up at reduced illumination and no ABS pump ramp up. Strong dash lights and ABS pump ramp up did not always guarantee starter engagement. When the starter did engage the bike started and ran normally.

  4. #4
    3 Red Bricks
    Join Date
    Jan 2007
    Location
    Pleasanton, Ca.
    Posts
    5,277
    I donít know if K12s have the same issue as early Ks, but it sounds like dirty ignition switch contacts or possibly dirty starter commutator.




    LONG MAY YOUR BRICK FLY!

    Ride Safe, Ride Far, Ride Often

    Lee Fulton Forum Moderator
    3 Marakesh Red K75Ss
    Mine, Hers, Spare

  5. #5

    03 K1200RS Electrical Gremlin

    I am wondering if its the AGM battery I have heard that some newer batteries will die without warning. Plenty of light but no amperage for starting.

  6. #6
    Fortis Fortuna Adiuvat Omega Man's Avatar
    Join Date
    Jan 2010
    Location
    Mansfield,MA
    Posts
    17,323
    I think the AGM batteries require a special charger.
    OM
    "You can do good or you can do well. Sooner or later they make you choose." MI5
    Mod Squad
    2009 F800GS 1994 TW200

  7. #7
    Registered User VIEJO's Avatar
    Join Date
    Feb 2013
    Location
    Hutto, Texas
    Posts
    122
    Quote Originally Posted by 98lee View Post
    I donít know if K12s have the same issue as early Ks, but it sounds like dirty ignition switch contacts or possibly dirty starter commutator.




    Thanks..... I'm leaning toward a faulty/dirty ignition switch myself.

  8. #8
    Registered User VIEJO's Avatar
    Join Date
    Feb 2013
    Location
    Hutto, Texas
    Posts
    122
    Quote Originally Posted by hfbmw View Post
    I am wondering if its the AGM battery I have heard that some newer batteries will die without warning. Plenty of light but no amperage for starting.
    I originally thought the battery might be suspect but as the problem was intermittent I've pretty much (but not quite 100% yet) ruled that out as I don't believe batteries will heal themselves.... although I am always amazed at the number of things that happen that "can't happen" with electrical systems.

  9. #9
    Registered User VIEJO's Avatar
    Join Date
    Feb 2013
    Location
    Hutto, Texas
    Posts
    122
    Quote Originally Posted by Omega Man View Post
    I think the AGM batteries require a special charger.
    OM
    My (BMW) battery tender/minder is rated for AGM.

Similar Threads

  1. Electrical Gremlin...
    By mwctexas in forum Airheads
    Replies: 6
    Last Post: 10-25-2018, 03:13 PM
  2. Electrical Gremlin
    By 174713 in forum Airheads
    Replies: 3
    Last Post: 06-07-2014, 04:29 AM
  3. Electrical gremlin ???????
    By jgr451 in forum Airheads
    Replies: 9
    Last Post: 08-12-2013, 04:16 PM
  4. R 65 Electrical Gremlin
    By ROLLIFAHRER in forum Airheads
    Replies: 5
    Last Post: 03-04-2012, 01:34 PM
  5. Another /6 electrical Gremlin
    By SPLINELUBE in forum Airheads
    Replies: 7
    Last Post: 03-02-2005, 05:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •