Results 1 to 2 of 2

Thread: 1990 K75 RT wierd current draw

  1. #1
    Nick Kennedy
    Join Date
    Nov 2011
    Location
    Telluride Colorado
    Posts
    177

    1990 K75 RT wierd current draw

    My 1990 K75 wouldn't crank last week, so I charged the battery [ a 4 yr old BMW Excide ] and it started right up.
    3 days later same thing, hmmmmmm
    I checked for a battery killing current draw via the Clymer manual instructions and found, of course, a current draw through the #3 from the top fuse; the clock and Turn signal fuse. I pulled the fuse, charged the battery and let it sit for a week and it fired right up. Is there something in that circuit other than the clock that could drain the battery quickly with the key off?
    Last night I charged the battery with the #3 fuse Out. Put a voltmeter on the battery, 12.5 v. Put the fuse in with the key off and watched the voltage slowly but steadily drop to 11v in about 15 minutes. Charged the battery overnight and did the same test and the battery is holding 12.5v now for several hours.

    Do I have a intermittent hi amperage draw or is the battery shot?

    Thanks in advance!

  2. #2
    Happily Bent dieselyoda's Avatar
    Join Date
    Mar 2013
    Location
    Winnipeg, MB, Canada
    Posts
    981

    A good electrical schematic is your best friend now.

    I have a really good electrical schematic but not for an RT so I don't know if they are the same as for a K75S.

    Got to admit, that was some damn fine troubleshooting to get it that close that quick. Good on you bud.
    1997 R1100RT (Restored Basket Case) , 1981 KZ 440 LTD (Restored Basket Case)
    3xR90/6, two just sold, one for a sidecar.
    1983 K100RS for winter project, two K's sold and just acquired a very rough R80RT.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •