Results 1 to 3 of 3

Thread: Odometer and trip distances different on 1991 K75RT

  1. #1
    Registered User WalterK75's Avatar
    Join Date
    Feb 2009
    Location
    Mississauga, Ontario
    Posts
    574

    Odometer and trip distances different on 1991 K75RT

    I just got back from a ride and noticed the difference between the odometer and trip distances recorded. I rode 88.00 kms and the odometer should have read 120,822 kms, but it read 120,924 kms! Off by 102 kms. First time I've ever seen this one. I don't mind putting on kms, but at least I should be actually riding them.

    I'm assuming the mechanism just clicked over improperly and it's a one time thing. Fingers crossed.

    Any other ideas about this?
    Walter

    All government, of course, is against liberty.
    H. L. Mencken

  2. #2
    A bozo on the bus deilenberger's Avatar
    Join Date
    Mar 2003
    Location
    Spring Lake NJ, USA
    Posts
    7,768
    There have been problems with the little plastic gears that operate the odometer on K bike instrument clusters.. they loose teeth. Usually that results in a non-working odometer, but I would guess if the lost tooth ended up in the wrong way, it could result in the odometer registering more miles than it should have. The odometer is driven by a small stepper motor in the cluster through a small gear-chain.

    There was someone somewhere who made replacement gears, and there was a writeup on replacing them, but I can't really recall where.. you might take a looksee on the IBMWR K-tech pages. If it was documented - that's likely where you'll find it. www.ibmwr.org
    Don Eilenberger http://www.eilenberger.net
    Spring Lk Heights NJ NJ Shore BMW Riders New Sweden BMW Riders
    '07 R1200R (current ride) and some bimmers.. and a Porsche

  3. #3
    Registered User
    Join Date
    Dec 2012
    Posts
    1,066
    Quote Originally Posted by WalterK75 View Post
    I just got back from a ride and noticed the difference between the odometer and trip distances recorded. I rode 88.00 kms and the odometer should have read 120,822 kms, but it read 120,924 kms! Off by 102 kms. First time I've ever seen this one. I don't mind putting on kms, but at least I should be actually riding them.

    I'm assuming the mechanism just clicked over improperly and it's a one time thing. Fingers crossed.

    Any other ideas about this?
    Perhaps the odometer measures the back wheel, and the trip meter measures the front wheel?

    JUST Kidding !!

    I was just trying to add a little levity!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •