Results 1 to 4 of 4

Thread: '05 K1200LT center stand problems

  1. #1
    havnablast2
    Guest

    '05 K1200LT center stand problems

    My motor is running but it's not moving the center stand. Any ideas.
    Is there a way to get these '05 on the center stand with out the motor? There doesn't seem to be anywhere to step on.
    Last edited by havnablast2; 06-06-2013 at 10:22 AM.

  2. #2
    Enjoy The Ride saddleman's Avatar
    Join Date
    Apr 2009
    Location
    Huntersville N.C.
    Posts
    340
    The 2005 to 2009 LT's have no way to lift them up on the center stand manually. I do know someone in Hazel Green Alabama who rebuilds them.
    Dave
    2004 Black LT
    2000 Canyon Red LT
    V.P. BMWMOA Club 220

  3. #3
    havnablast2
    Guest
    Quote Originally Posted by saddleman View Post
    The 2005 to 2009 LT's have no way to lift them up on the center stand manually. I do know someone in Hazel Green Alabama who rebuilds them.
    That would be great if yo could foward me the information. I'll look into it.
    Thanks
    have a great day

  4. #4
    Registered User jzeiler4's Avatar
    Join Date
    Feb 2007
    Location
    North Alabama
    Posts
    4
    Quote Originally Posted by havnablast2 View Post
    That would be great if yo could foward me the information. I'll look into it.
    Thanks
    have a great day
    Hi,

    I have a couple of options for you. 1. You can send me your unit and I can rebuild it and return it or 2. I can send you a rebuilt unit and you return your old one as a core. I'll PM you with the details. I don't post here very often but am very active on the bmwlt.com site. My good friend Dave (saddleman) sent me the tip you were looking.

    John
    2005 LT
    2009 GS

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •