Results 1 to 10 of 10

Thread: Crazy Speedometer

Hybrid View

  1. #1
    Robert E
    Join Date
    Apr 2006
    Location
    Victoria, Texas
    Posts
    115

    Crazy Speedometer

    I have a 1978 R80/7 that I have had since new.... I have noticed lately that on the highway at highway speeds the speedometer needle will start to gain speed. It will eventually go all the way up to 140 mph. The "odometer" is working normally even when the speedometer needle is smoothly hovering over towards 140 mph.

    It is not erratic like the cable is binding. It is more like the speedometer is getting to much voltage. This only happens after you have been riding on the highway a while. It acts normal around town.

    I was wondering if a part is failing; or, it I might have a bad ground??? Any ideas???

  2. #2
    Sir Darby Darryl Cainey's Avatar
    Join Date
    Mar 2003
    Location
    Fenwick, Ontario Canada
    Posts
    2,208
    The speedo is driven from the transmission through the cable mechanicley not electricley.

    .First replace the cable to see if it helps, if not, speedo may need a rebuild.

    good luck!
    Last edited by DARRYL CAINEY; 10-21-2012 at 07:02 PM. Reason: sp
    Ambassador BMW MOA Ontario Canada
    President Niagara BMW Riders #298
    Knights of the Roundel #333
    1977 R100RS, (Retired) 1993 R100GS (just getting started)

  3. #3
    Robert E
    Join Date
    Apr 2006
    Location
    Victoria, Texas
    Posts
    115
    I don't think it is the cable as everything is very smooth. In the past I have had speedo cables that went bad... This one acts like something is going on in the speedo head.

    If someone has had this experience before maybe they can tell me what is going on. Otherwise I will contact a speedo repair shop... There is one near here in Austin; and one in California.

    Thanks.

  4. #4
    #4869 DennisDarrow's Avatar
    Join Date
    Jan 2006
    Location
    Sugar Valley, Ga
    Posts
    1,135
    99% chance that it is the speedometer itself......Before it begins to self-destruct get to the ol boy over in Austin......Good guy, honest, and a craftsman......You could try taking the instrument out and spraying the workings with some SILICONE spray and try it; but mostly it probably just needs a good cleaning and lube before it does the sooner or later needle bounce and screaming mode...................God bless and good luck.......Dennis

  5. #5
    Robert E
    Join Date
    Apr 2006
    Location
    Victoria, Texas
    Posts
    115
    Thanks Dennis... I used him to calibrate the speedometer many years ago. He is a very nice guy... I will give him a call.

  6. #6
    Registered User bmweuro's Avatar
    Join Date
    Oct 2009
    Location
    Northern Cal
    Posts
    255
    Over time the cable goes bad and it creates a vibration that will tear the speed cup apart on the back side of the speedo. Take the cable off at the back side of the speedo and spray something like WD40 down the speedo cable and see if that helps a little bit. If it does it's your cable.

    When and if you have the speedo rebuilt make sure to buy a new cable.
    www.boxermetal.com
    www.facebook.com/boxermetal
    VBMWMO #7770, BMW MOA #48694, ABC #600
    Hi my name is Chris and I am a slash-five-o-holic.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •